Closed Bug 1635825 Opened 2 years ago Closed 1 year ago

Separate startpage locking from homepage locking

Categories

(Firefox :: Enterprise Policies, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 78
Tracking Status
firefox78 --- fixed

People

(Reporter: mkaply, Assigned: mkaply)

References

Details

Attachments

(1 file)

Currently because of the way browser.startup.page is set, if you lock the homepage so users can't change it, it also means they can't turn restore previous session on/off.

In policy, we should make it possible to lock the homepage but still allow the user to turn restore previous session on/off.

Severity: -- → S3
Priority: -- → P3
Assignee: nobody → mozilla
Status: NEW → ASSIGNED

So the route I went is to introduce a new parameter, homepage-locked if you need to explicitly lock the homepage and prevent the user from selecting restore session.

I do not provide a way to lock restore session anymore (I think that's OK).

So this should give folks the old behavior if they want it (always start with a homepage no matter what), and the new behavior which is to not lock startpage.

Duplicate of this bug: 1611598
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/f3ac98c968db
Don't lock Startpage preference by default. r=mconley
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
You need to log in before you can comment on or make changes to this bug.