Closed Bug 1636019 Opened 5 months ago Closed 5 months ago

Remove the remaining uses of nsIAbView and get rid of it

Categories

(MailNews Core :: Address Book, task)

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 78.0

People

(Reporter: darktrojan, Assigned: darktrojan)

References

Details

Attachments

(1 file)

No description provided.

In bug 1633620 I ported all but one use of nsAbView to JS. With this I get rid of the remaining use, which was to gather the cards in one or all address books and sort them for printing. I've moved that code in with the printing code.

Throwing away the interface means I can't use tree.view to access the extra functions it provided (because tree.view only gives you an nsITreeView not the real object) but that's okay because we kept a reference to the current view anyway. I had to fix some things to use that reference.

I also discovered some of the functions of nsIAbView are there to support some UI interface stuff that AFAICT has been broken for a long time (and with no bugs complaining about the brokenness) so I've just removed it.

Attachment #9146398 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9146398 [details] [diff] [review]
1636019-remove-nsiabview-1.diff

Review of attachment 9146398 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. I think the swapping of the order of names would be useful, but mostly on a per-card level to fix it up.
Attachment #9146398 - Flags: review?(mkmelin+mozilla) → review+

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/a8bc54c5c793
Remove the remaining uses of nsIAbView, then remove it and nsAbView. r=mkmelin DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 78.0
Regressions: 1644084
You need to log in before you can comment on or make changes to this bug.