Closed Bug 1644084 Opened 2 months ago Closed 2 months ago

After deleting contact from search results in contacts sidebar, entire result set disappears

Categories

(Thunderbird :: Address Book, defect)

defect
Not set
normal

Tracking

(thunderbird_esr78 fixed, thunderbird79 fixed)

RESOLVED FIXED
Thunderbird 80.0
Tracking Status
thunderbird_esr78 --- fixed
thunderbird79 --- fixed

People

(Reporter: bugzilla2007, Assigned: darktrojan)

References

(Regression)

Details

(Keywords: regression, ux-mode-error)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1619157 +++

STR

  1. composition with contacts side bar, ensure "All Address Books" is shown
  2. Filter for "Doe" so that you get a couple of matches in the search result
  3. select and delete a contact from search result (contact originates from "Personal AB")
  4. press DEL and confirm deletion, then monitor the rest of your result set in results pane
  5. Try other variants:
  • delete contact from "All Address Books" without search filter
  • delete contact from "Personal AB" with and without search filter
  • try all variants with deleting a mailing list

Actual result

  • deleting contact from search result of "All ABs" succeeds, but makes the entire result set disappear (blank results pane)
  • deleting contact from unfiltered "Personal AB" ends up with a bogus icon-only item at the end of the list which cannot be deleted.
  • deleting mailing list sometimes failed

Expected:

  • delete/remove only selected items
  • keep showing any other items (of result set, or current AB)
  • handle focus after deletion
Keywords: ux-mode-error

Before the regression window:
#1 if last item is deleted in the sidebar list, a blank item is remained.
#2 if middle item is deleted in the sidebar list, last item is visually duplicated.

After the regression window:
All items disappear in the sidebar list.

Regression window:
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=c5def570bb4b97b043bf35eda9df5f08fe996109&tochange=96995bd8f55c685952d95b51fdb1c0a8f10c05a9
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ead8f0367372fe5767d33a0aa0a95b07ee76ea75&tochange=19e273db80195cc5de59647fcaf16bafad9bbcce

Suspect: Bug 1636019

Regressed by: 1636019

Thank you Alice!!
So we can remove regressionwindow-wanted because you found it.

Together with similar bug 1644026, that makes contacts side bar quite broken...

See Also: → 1644026

Geoff, from your experience in Bug 1639750, any insights here?

Flags: needinfo?(geoff)

This call to SetABView() is bogus, we should never call that without arguments. Fortunately all of this block of code is redundant because ABView.deleteSelectedCards does the same thing.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Flags: needinfo?(geoff)
Attachment #9160566 - Flags: review?(rob)
Attachment #9160566 - Flags: review?(rob) → review+

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/926e7403d2a8
Remove redundant code for deleting contacts. r=rjl

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 80.0
Comment on attachment 9160566 [details] [diff] [review]
1644084-delete-selected-cards-1.diff

I want this bad UX to be fixed in 78.1.
Attachment #9160566 - Flags: approval-comm-beta?
Attachment #9160566 - Flags: approval-comm-esr78?
Comment on attachment 9160566 [details] [diff] [review]
1644084-delete-selected-cards-1.diff

Approved for 79 beta, to prepare for 78
Attachment #9160566 - Flags: approval-comm-beta? → approval-comm-beta+
Comment on attachment 9160566 [details] [diff] [review]
1644084-delete-selected-cards-1.diff

Approved for esr78 (low risk)
Attachment #9160566 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.