Closed Bug 1636238 Opened 10 months ago Closed 10 months ago

Convert remaining PNG icons to SVG for visual consistency

Categories

(Thunderbird :: Theme, enhancement)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 78.0

People

(Reporter: aleca, Assigned: Paenglab)

Details

Attachments

(7 files, 2 obsolete files)

Attached image icons.png

We're using some PNGs around the app which should be converted to SVGs and complete the visual refresh to better support HiDPI monitors and improve UI consistency.

After a quick investigation, these are the sections that present replaceable icons:

  • Account settings richilist for IM accounts.
  • Chat contacts and availability indicator.
  • Compose Address Book menu item.
  • Missing primary icon in the Get Messages dropdown menulist.
  • Online/Offline indicator in the status bar.

Attachment for reference.

Magnus, FX removed all icons from the menus on Linux, Mac and Windows have none.

What do you think about removing them on TB too? Then we are in synch with Mac and Windows. The issue is also that we have no HiDPI icons, like the AB icon in composer menu, that look good on HiDPI Linux desktops.

Using SVG icons is also no option as they don't fit with the native icons we also use.

Flags: needinfo?(mkmelin+mozilla)

It's a bit of a shame, but gtk stock icons are deprecated, so I guess it's time to let go.

Flags: needinfo?(mkmelin+mozilla)
Attached patch 1636238-apply-more-SVG.patch (obsolete) — Splinter Review

This patch implements the things you wrote in comment 0 except the IM parts. They should be done in bug 827092.

I also removed a lot of not used icons. In total 120 icons removed.

Attachment #9147349 - Flags: review?(alessandro)

Forgot to mention: this patch removes the menu icons on Linux. Mac and Windows have done this already long time ago.

Massive patch!
Thank you so much for taking care of this. I'll take some time to review and be sure to check every single section and line of code.
Apologies for the wait.