Closed Bug 1636511 Opened 6 months ago Closed 6 months ago

Disable the OS authentication prompt from about:logins due to abnormally high failure rate

Categories

(Firefox :: about:logins, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 77
Tracking Status
firefox76 + fixed
firefox77 + verified
firefox78 --- unaffected

People

(Reporter: jaws, Assigned: jaws)

References

Details

Attachments

(1 file)

Through telemetry we are seeing an abnormally high failure rate, and have seen multiple bug reports reporting that users are getting prompted when they do not have a password set, or are getting prompted to authenticate via smartcard on their portable machine without ability to use a password.

Further, some users are confused as to which password to supply (Firefox Account password vs OS account password). We are actively discussing updating the string to make this clearer to users but this will likely be a Firefox 78 change at this point.

I would like to disable this feature for users on all platforms via Normandy by setting the signon.management.page.os-auth.enabled pref to false.

Depends on: 1636588
Summary: Disable the OS authentication prompt on Windows due to abnormally high failure rate → Disable the OS authentication prompt from about:logins due to abnormally high failure rate

Comment on attachment 9147286 [details]
Bug 1636511 - Disable the OS auth feature in about:logins on Release and Beta.

Beta/Release Uplift Approval Request

  • User impact if declined: High percentage of users unable to retrieve or edit stored passwords in about:logins
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Pref-flip to disable the feature, the preference has been tested by QA.
  • String changes made/needed: none
Attachment #9147286 - Flags: approval-mozilla-release?
Attachment #9147286 - Flags: approval-mozilla-beta?

Comment on attachment 9147286 [details]
Bug 1636511 - Disable the OS auth feature in about:logins on Release and Beta.

Planned uplift, approved for beta 6, thanks.

Attachment #9147286 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77

Comment on attachment 9147286 [details]
Bug 1636511 - Disable the OS auth feature in about:logins on Release and Beta.

No plans for another 76 dot release at this time, but let's get this landed for parity's sake with the pref rollout in the event that there is.

Attachment #9147286 - Flags: approval-mozilla-release? → approval-mozilla-release+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I have verified this issue and the OS auth feature is correctly disabled.

  • Tested on Firefox Beta 77.0b6 (Build ID: 20200514211331): the OS auth feature is disabled and the pref "signon.management.page.os-auth.enabled" is set to "false" by default.
  • Tested on Firefox 76.0 release: the feature is disabled and the pref is correctly set to "false" by the rollout

Tested on Windows 10 x64, Windows 8.1 x32, Windows 7 x64, Mac 10.14.6, Mac 10.13.6 and Ubuntu 18.04 x64.
However, I will not change the "firefox76' status to "verified" since we don't have a dot release so we can verify this fix. But, on Firefox 76 release, we have verified that the rollout correctly disables the feature.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Depends on: 1641301
Depends on: 1641302
Depends on: 1641473
You need to log in before you can comment on or make changes to this bug.