Closed Bug 1637687 Opened 2 years ago Closed 1 year ago

Front errors thrown when viewing tabs after connecting to device

Categories

(DevTools :: about:debugging, task, P3)

task

Tracking

(firefox78 fixed)

RESOLVED FIXED
Firefox 78
Tracking Status
firefox78 --- fixed

People

(Reporter: davidwalsh, Assigned: jdescottes)

References

Details

Attachments

(4 files)

Attached image FrontErrors.png

I attached my Pixel 4 and started looking at the tab list; saw a bunch of front errors:

onPacket/<@resource://devtools/shared/protocol/Front.js:319:31
DevTools RDP*request@resource://devtools/shared/protocol/Front.js:256:14
generateRequestMethods/</frontProto[name]@resource://devtools/shared/protocol/Front/FrontClassWithSpec.js:47:19
requestWorkers/<@resource://devtools/client/aboutdebugging/src/actions/debug-targets.js:317:54
async*thunk/</<@resource://devtools/client/shared/redux/middleware/thunk.js:15:9
dispatch@resource://devtools/client/shared/vendor/redux.js:681:28
watchRuntime/<@resource://devtools/client/aboutdebugging/src/actions/runtimes.js:334:15
async*thunk/</<@resource://devtools/client/shared/redux/middleware/thunk.js:15:9
dispatch@resource://devtools/client/shared/vendor/redux.js:681:28
selectPage/<@resource://devtools/client/aboutdebugging/src/actions/ui.js:85:15
thunk/</<@resource://devtools/client/shared/redux/middleware/thunk.js:15:9
componentWillMount@resource://devtools/client/aboutdebugging/src/components/RuntimePage.js:107:13
callComponentWillMount@resource://devtools/client/shared/vendor/react-dom.js:8286:14
mountClassInstance@resource://devtools/client/shared/vendor/react-dom.js:8345:27
updateClassComponent@resource://devtools/client/shared/vendor/react-dom.js:10593:23
beginWork@resource://devtools/client/shared/vendor/react-dom.js:11419:16
performUnitOfWork@resource://devtools/client/shared/vendor/react-dom.js:14702:12
workLoop@resource://devtools/client/shared/vendor/react-dom.js:14720:24
renderRoot@resource://devtools/client/shared/vendor/react-dom.js:14803:15
performWorkOnRoot@resource://devtools/client/shared/vendor/react-dom.js:15655:17
performWork@resource://devtools/client/shared/vendor/react-dom.js:15567:24
performSyncWork@resource://devtools/client/shared/vendor/react-dom.js:15541:14
requestWork@resource://devtools/client/shared/vendor/react-dom.js:15410:5
scheduleWork@resource://devtools/client/shared/vendor/react-dom.js:15224:16
scheduleRootUpdate@resource://devtools/client/shared/vendor/react-dom.js:15865:15
updateContainerAtExpirationTime@resource://devtools/client/shared/vendor/react-dom.js:15881:10
updateContainer@resource://devtools/client/shared/vendor/react-dom.js:15908:10
ReactRoot.prototype.render@resource://devtools/client/shared/vendor/react-dom.js:16133:18
legacyRenderSubtreeIntoContainer/<@resource://devtools/client/shared/vendor/react-dom.js:16242:14
unbatchedUpdates@resource://devtools/client/shared/vendor/react-dom.js:15772:10
legacyRenderSubtreeIntoContainer@resource://devtools/client/shared/vendor/react-dom.js:16238:21
render@resource://devtools/client/shared/vendor/react-dom.js:16289:12
init@resource://devtools/client/aboutdebugging/aboutdebugging.js:115:11
async*@resource://devtools/client/aboutdebugging/aboutdebugging.js:191:20
EventListener.handleEvent*@resource://devtools/client/aboutdebugging/aboutdebugging.js:188:8
load@resource://devtools/shared/base-loader.js:160:27
_require@resource://devtools/shared/base-loader.js:346:23
requireHook@resource://devtools/client/shared/browser-loader.js:185:14
require@resource://devtools/shared/base-loader.js:300:14
@resource://devtools/client/aboutdebugging/initializer.js:23:8
error-logging.js:27:17

I can't reproduce this on my phone, with the same build of Firefox Preview Nightly.

David: Did it lead to any issue in the UI? If you can consistently reproduce, can you share the detailed STRs?

Triaging as S3/P3 for now.

Severity: -- → S3
Type: defect → task
Flags: needinfo?(dwalsh)
Priority: -- → P3
Attached file Error stack trace
STR:

1.  Go to about:debugging with the browser toolbox open
2.  Click "connect" next to your phone (in my case Google Pixel 4)

Immediately see the following in both the browse console and browser toolbox console:

```
[ACTION FAILED] REQUEST_WORKERS_FAILURE: unknownError from: server0.conn7.serviceWorkerRegistration37 error-logging.js:16:17
onPacket/<@resource://devtools/shared/protocol/Front.js:319:31
DevTools RDP*request@resource://devtools/shared/protocol/Front.js:256:14
generateRequestMethods/</frontProto[name]@resource://devtools/shared/protocol/Front/FrontClassWithSpec.js:47:19
requestWorkers/<@resource://devtools/client/aboutdebugging/src/actions/debug-targets.js:317:54
async*thunk/</<@resource://devtools/client/shared/redux/middleware/thunk.js:15:9
dispatch@resource://devtools/client/shared/vendor/redux.js:681:28
watchRuntime/<@resource://devtools/client/aboutdebugging/src/actions/runtimes.js:334:15
async*thunk/</<@resource://devtools/client/shared/redux/middleware/thunk.js:15:9
dispatch@resource://devtools/client/shared/vendor/redux.js:681:28
selectPage/<@resource://devtools/client/aboutdebugging/src/actions/ui.js:85:15
thunk/</<@resource://devtools/client/shared/redux/middleware/thunk.js:15:9
componentWillMount@resource://devtools/client/aboutdebugging/src/components/RuntimePage.js:107:13
callComponentWillMount@resource://devtools/client/shared/vendor/react-dom.js:8286:14
mountClassInstance@resource://devtools/client/shared/vendor/react-dom.js:8345:27
updateClassComponent@resource://devtools/client/shared/vendor/react-dom.js:10593:23
beginWork@resource://devtools/client/shared/vendor/react-dom.js:11419:16
performUnitOfWork@resource://devtools/client/shared/vendor/react-dom.js:14702:12
workLoop@resource://devtools/client/shared/vendor/react-dom.js:14720:24
renderRoot@resource://devtools/client/shared/vendor/react-dom.js:14803:15
performWorkOnRoot@resource://devtools/client/shared/vendor/react-dom.js:15655:17
performWork@resource://devtools/client/shared/vendor/react-dom.js:15567:24
performSyncWork@resource://devtools/client/shared/vendor/react-dom.js:15541:14
interactiveUpdates$1@resource://devtools/client/shared/vendor/react-dom.js:15808:7
interactiveUpdates@resource://devtools/client/shared/vendor/react-dom.js:1901:10
dispatchInteractiveEvent@resource://devtools/client/shared/vendor/react-dom.js:4328:21
EventListener.handleEvent*addEventBubbleListener@resource://devtools/client/shared/vendor/react-dom.js:3754:11
trapBubbledEvent@resource://devtools/client/shared/vendor/react-dom.js:4302:25
listenTo@resource://devtools/client/shared/vendor/react-dom.js:4489:29
ensureListeningTo@resource://devtools/client/shared/vendor/react-dom.js:5720:11
setInitialDOMProperties@resource://devtools/client/shared/vendor/react-dom.js:5777:26
setInitialProperties@resource://devtools/client/shared/vendor/react-dom.js:5929:26
finalizeInitialChildren@resource://devtools/client/shared/vendor/react-dom.js:6416:23
completeWork@resource://devtools/client/shared/vendor/react-dom.js:12601:40
completeUnitOfWork@resource://devtools/client/shared/vendor/react-dom.js:14566:26
performUnitOfWork@resource://devtools/client/shared/vendor/react-dom.js:14708:12
workLoop@resource://devtools/client/shared/vendor/react-dom.js:14720:24
renderRoot@resource://devtools/client/shared/vendor/react-dom.js:14803:15
performWorkOnRoot@resource://devtools/client/shared/vendor/react-dom.js:15655:17
performWork@resource://devtools/client/shared/vendor/react-dom.js:15567:24
performSyncWork@resource://devtools/client/shared/vendor/react-dom.js:15541:14
requestWork@resource://devtools/client/shared/vendor/react-dom.js:15410:5
scheduleWork@resource://devtools/client/shared/vendor/react-dom.js:15224:16
scheduleRootUpdate@resource://devtools/client/shared/vendor/react-dom.js:15865:15
updateContainerAtExpirationTime@resource://devtools/client/shared/vendor/react-dom.js:15881:10
updateContainer@resource://devtools/client/shared/vendor/react-dom.js:15908:10
ReactRoot.prototype.render@resource://devtools/client/shared/vendor/react-dom.js:16133:18
legacyRenderSubtreeIntoContainer/<@resource://devtools/client/shared/vendor/react-dom.js:16242:14
unbatchedUpdates@resource://devtools/client/shared/vendor/react-dom.js:15772:10
legacyRenderSubtreeIntoContainer@resource://devtools/client/shared/vendor/react-dom.js:16238:21
render@resource://devtools/client/shared/vendor/react-dom.js:16289:12
init@resource://devtools/client/aboutdebugging/aboutdebugging.js:115:11
async*@resource://devtools/client/aboutdebugging/aboutdebugging.js:191:20
EventListener.handleEvent*@resource://devtools/client/aboutdebugging/aboutdebugging.js:188:8
load@resource://devtools/shared/base-loader.js:160:27
_require@resource://devtools/shared/base-loader.js:346:23
requireHook@resource://devtools/client/shared/browser-loader.js:185:14
require@resource://devtools/shared/base-loader.js:300:14
@resource://devtools/client/aboutdebugging/initializer.js:23:8
error-logging.js:27:17

​


```
Flags: needinfo?(dwalsh)

I just got a similar error while trying to connect to Firefox Preview Release, although it was a bit clearer:

console.error: "[ACTION FAILED] REQUEST_WORKERS_FAILURE: Protocol error (unknownError): Method not implemented'Method not implemented' when calling method: [nsIPushSubscription::pushCount] from: server0.conn0.serviceWorkerRegistration40"

And it seems that pushCount is not implemented on GeckoView:
https://searchfox.org/mozilla-central/rev/9193635dca8cfdcb68f114306194ffc860456044/mobile/android/components/geckoview/GeckoViewPush.js#183

Components.Exception("", Cr.NS_ERROR_NOT_IMPLEMENTED);

It most likely only happens if you register a service worker using push, which might explain why we didn't spot it before.
We read the information athttps://searchfox.org/mozilla-central/rev/9193635dca8cfdcb68f114306194ffc860456044/devtools/server/actors/worker/push-subscription.js#25

See Also: → 1639111
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Attachment #9150052 - Attachment description: Bug 1637687 - Catch remote debugging errors with push subscription on GeckoView → Bug 1637687 - Remove lastPush/pushCount from PushSubscriptionActor as they are not supported on GeckoView
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dde01bd41c4d
Remove lastPush/pushCount from PushSubscriptionActor as they are not supported on GeckoView r=davidwalsh,daisuke
https://hg.mozilla.org/integration/autoland/rev/1393662c8ab8
Catch push subscription actor errors in about:debugging r=davidwalsh,daisuke
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
Regressions: 1697088
No longer regressions: 1697088
You need to log in before you can comment on or make changes to this bug.