Closed Bug 1638101 Opened 6 months ago Closed 5 months ago

Support GetStarted and Import Screens UI theme in multistage about:welcome

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 78
Iteration:
78.2 - May 18 - May 31
Tracking Status
firefox77 --- unaffected
firefox78 --- verified

People

(Reporter: pdahiya, Assigned: pdahiya)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Update Multi Stage about welcome to support styles used in Get Started and Import Screens from UI specs here

https://www.figma.com/proto/KqQZwwLhft9cUIcBtMVmbz/Desktop-First-Run?node-id=45%3A2470&viewport=-321%2C179%2C0.22833333909511566&scaling=min-zoom

Assignee: nobody → pdahiya

Punam, here is the updated Figma link with the spec included. This is the first time I've handed off specs using Figma so we may need to learn a bit together. I think you can create a free Figma account which would let you see all of the styling and measurement information in the doc. Ping me if you want to take a look together or get stuck. Thanks!

https://www.figma.com/file/KqQZwwLhft9cUIcBtMVmbz/Desktop-First-Run?node-id=638%3A63

Severity: -- → S3
Iteration: --- → 78.2 - May 18 - May 31
Priority: -- → P1

(In reply to Aaron Benson from comment #2)

Punam, here is the updated Figma link with the spec included. This is the first time I've handed off specs using Figma so we may need to learn a bit together. I think you can create a free Figma account which would let you see all of the styling and measurement information in the doc. Ping me if you want to take a look together or get stuck. Thanks!

https://www.figma.com/file/KqQZwwLhft9cUIcBtMVmbz/Desktop-First-Run?node-id=638%3A63

Figma works great, Thanks Aaron!

Pushed by pdahiya@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9556c4aaac77
Multistage about:welcome Get Started and Import Settings UI r=Mardak
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78

I have verified that the Get Started and Import Settings UI is displayed when navigating to the about:welcome page, if the browser.aboutwelcome.overrideContent pref is set to the value from this gist.

  • The Sign in button from the top right corner redirects to the FxA login flow.
  • The Start Setup button proceeds to the next stage.
  • The Start Import button redirects to the about:newtab page and triggers the Import wizard.
  • The Not now button redirects to the about:newtab page.

The verification was performed on the latest Nightly (78.0a1, Build ID 20200528032513) using Windows 10, macOS 10.15.4, and Linux MX 4.19.

Status: RESOLVED → VERIFIED
Duplicate of this bug: 1335445
You need to log in before you can comment on or make changes to this bug.