Closed Bug 1638223 Opened 2 years ago Closed 2 years ago

Clicking on the reader mode toolbar buttons closes and immediately reopens the menus

Categories

(Toolkit :: Reader Mode, defect, P3)

76 Branch
defect

Tracking

()

VERIFIED WORKSFORME
Tracking Status
firefox78 --- fixed

People

(Reporter: mathew.hodson, Unassigned)

References

Details

(Whiteboard: [about-reader-ui])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:76.0) Gecko/20100101 Firefox/76.0

Steps to reproduce:

  1. Go to https://getpocket.com/explore/item/this-is-your-brain-on-architecture
  2. Press F9 to toggle reader view
  3. Click the text or voice control button in the reader mode toolbar
  4. Click the button again

Actual results:

The menu flashes as it closes and reopens instantly.

Expected results:

The menu should close.

I can also reproduce on Nightly 78.0a1 build ID 20200513094918

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Reader Mode
Product: Firefox → Toolkit
Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Whiteboard: [about-reader-ui]
Summary: Clicking on the reader mode toolbar buttons doesn't close the menu → Clicking on the reader mode toolbar buttons closes and immediately reopens the menus

The root cause here was a mousedown listener that closes all open popups, and a click listener that opens them. So if you clicked the anchor, as soon as you mousedown, the popup closed, and when the mouseup and click event happened, we reopened the popup.

I believe this is now fixed as a side-effect of some CSS/design considerations in bug 1637652 - the sidebar/toolbar now has pointer-events: none when there are open popups (to ensure no hover effects appear when a dropdown is open, because they conflict with each other), which means that no click event fires on the button, as it doesn't receive the mousedown event.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
Depends on: 1637652

Verified that the menus now close on click with Nightly build 20200523092124.

Status: RESOLVED → VERIFIED
See Also: → 1669112
You need to log in before you can comment on or make changes to this bug.