Closed Bug 1638508 Opened 4 months ago Closed 4 months ago

Intermittent remote/test/browser/network/browser_navigationEvents.js | Page.navigate returns before first lifecycle event -

Categories

(Remote Protocol :: Agent, defect, P5)

defect

Tracking

(firefox77 unaffected, firefox78 fixed)

RESOLVED FIXED
Firefox 78
Tracking Status
firefox77 --- unaffected
firefox78 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: whimboo)

References

(Regression)

Details

(Keywords: intermittent-failure)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=302549051&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/CTarY-8LSgOHCeec4adLDA/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/CTarY-8LSgOHCeec4adLDA/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[task 2020-05-16T02:28:08.223Z] 02:28:08 INFO - TEST-PASS | remote/test/browser/network/browser_navigationEvents.js | Page.navigate returns after document response -
[task 2020-05-16T02:28:08.231Z] 02:28:08 INFO - TEST-PASS | remote/test/browser/network/browser_navigationEvents.js | Page.navigate returns before resource request -
[task 2020-05-16T02:28:08.231Z] 02:28:08 INFO - Buffered messages finished
[task 2020-05-16T02:28:08.240Z] 02:28:08 INFO - TEST-UNEXPECTED-FAIL | remote/test/browser/network/browser_navigationEvents.js | Page.navigate returns before first lifecycle event -
[task 2020-05-16T02:28:08.240Z] 02:28:08 INFO - Stack trace:
[task 2020-05-16T02:28:08.240Z] 02:28:08 INFO - chrome://mochikit/content/browser-test.js:test_ok:1299
[task 2020-05-16T02:28:08.240Z] 02:28:08 INFO - chrome://mochitests/content/browser/remote/test/browser/network/browser_navigationEvents.js:documentNavigationWithScriptResource:78
[task 2020-05-16T02:28:08.240Z] 02:28:08 INFO - chrome://mochitests/content/browser/remote/test/browser/head.js:fn:69
[task 2020-05-16T02:28:08.240Z] 02:28:08 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1064
[task 2020-05-16T02:28:08.240Z] 02:28:08 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1104
[task 2020-05-16T02:28:08.240Z] 02:28:08 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:921
[task 2020-05-16T02:28:08.240Z] 02:28:08 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:918
[task 2020-05-16T02:28:08.240Z] 02:28:08 INFO - TEST-PASS | remote/test/browser/network/browser_navigationEvents.js | Got the doc response -
[task 2020-05-16T02:28:08.240Z] 02:28:08 INFO - TEST-PASS | remote/test/browser/network/browser_navigationEvents.js | Doc response frame id matches that of doc request -

Summary: Intermittent TV remote/test/browser/network/browser_navigationEvents.js | Page.navigate returns before first lifecycle event - → Intermittent remote/test/browser/network/browser_navigationEvents.js | Page.navigate returns before first lifecycle event -

Maja, can you please keep an eye on that failure?

Flags: needinfo?(mjzffr)

Note that I update that tests while working on bug 1637363. So maybe I can already figure out the reason and fix it.

Depends on: 1637363

The test setup seems fine to me. I wonder whether checking that navigate returns before init is important in the first place. While it does match the behaviour in Chrome CDP logs, I don't see any checks for anything like that in their unit tests.

Right, I think at least for the network tests we do not have to check for the lifecycleEvent order. The only important bit here is the loaderId that this is equal. I will have that already changed in my upcoming patch for the other bug.

Flags: needinfo?(mjzffr)

We removed the checks for the lifecycle events on bug 1637363. So this won't fail anymore.

Assignee: nobody → hskupin
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
You need to log in before you can comment on or make changes to this bug.