Closed Bug 1638908 Opened 2 months ago Closed 2 months ago

Uplift the en-US Windows reauthentication string to beta for limited testing while the feature is disabled by default

Categories

(Firefox :: about:logins, task, P1)

task

Tracking

()

VERIFIED FIXED
Firefox 77
Tracking Status
firefox76 --- unaffected
firefox77 + verified
firefox78 --- unaffected

People

(Reporter: jaws, Assigned: jaws)

References

Details

Attachments

(1 file, 1 obsolete file)

The OS reauthentication feature has been disabled by default in bug 1636511.

We believe that the updated string from bug 1636032 will help our conversion rates.

We would like to uplift the string from bug 1636032 to beta, and then we can use Normandy to re-enable the feature for a select set of users and see if their success rate increases.

Comment on attachment 9149935 [details]
Bug 1638908 - Uplift the string changes for about:logins OS reauthentication to 77 for testing with Normandy. r=MattN!

Revision D74455 was moved to bug 1636032. Setting attachment 9149935 [details] to obsolete.

Attachment #9149935 - Attachment is obsolete: true

Comment on attachment 9149937 [details]
Bug 1638908 - Uplift the string changes for about:logins OS reauthentication to 77 for testing with Normandy. r=MattN!

Beta/Release Uplift Approval Request

  • User impact if declined: Delay delivering of using OS authentication for about:logins. We want to uplift this to run a Normandy study in Fx77 with a subset of users in specific locales in order to see whether the new string and bug 1631879 helped address issues we saw in Fx76.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Low, this is just existing m-c patches squashed for Beta
  • String changes made/needed: Yes, but it seems like Flod is fine with it since the feature won't be exposed to users in locales where we don't confirm the strings are fully translated. We will only test this with a small number of users on specific locales, maybe only en-US.
Attachment #9149937 - Flags: approval-mozilla-beta?

(In reply to Matthew N. [:MattN] (PM me if request are blocking you) from comment #4)

  • String changes made/needed: Yes, but it seems like Flod is fine with it since the feature won't be exposed to users in locales where we don't confirm the strings are fully translated. We will only test this with a small number of users on specific locales, maybe only en-US.

Confirming that it's OK, since the conversation happened elsewhere (I think Phabricator). We're past sign-off on Beta, and we'll have some translations to test thanks to cross-channel.

Comment on attachment 9149937 [details]
Bug 1638908 - Uplift the string changes for about:logins OS reauthentication to 77 for testing with Normandy. r=MattN!

Low risk as this is for a deactivated feature and l10n team is onboard, approved for out last beta, thanks.

Attachment #9149937 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77

I have verified this issue and the strings are correctly displayed and updated when trying to show, copy, edit a password, or create a Master Password. I have verified this using the latest Beta 78.0b9 (Build ID: 20200521224544) on Windows 10 x64, Windows 8.1 x32, and Windows 7 x64.

I have also verified if there are no issues on Linux where the feature is not supported. Tested on Beta 78.0b9 (Build ID: 20200521224544) on Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.