Closed Bug 1638949 Opened 11 months ago Closed 1 month ago

Convert 'mach awsy-test' to run with Python 3

Categories

(Testing :: General, task, P3)

task

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1697048

People

(Reporter: KrisWright, Unassigned)

References

(Blocks 1 open bug)

Details

mach awsy-test still runs with python 2 [1]. We want to convert all mach commands to python 3.

To do this, any dependencies of the command may need to be converted as well as the command itself.

[1] https://searchfox.org/mozilla-central/rev/9193635dca8cfdcb68f114306194ffc860456044/testing/awsy/mach_commands.py

Severity: -- → S3
Priority: -- → P3
Assignee: nobody → bob
Status: NEW → ASSIGNED

I'm un-assigning myself until the time where we have more of the underlying infrastructure ported to support python3.

Assignee: bob → nobody
Status: ASSIGNED → NEW
Assignee: nobody → whole.grains

I understand :bc has some work in progress here -- I'll leave this to him.

Here are my efforts, still with some rough edges:
https://treeherder.mozilla.org/jobs?repo=try&revision=6467e9465182e15850d90134ceb8bf17ab37feb0

Assignee: whole.grains → nobody

This got fixed as part of bug 1697048

Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1697048
You need to log in before you can comment on or make changes to this bug.