Closed Bug 1638974 Opened 11 months ago Closed 7 months ago

Convert 'mach mochitest' to run with Python 3

Categories

(Testing :: Mochitest, task)

task

Tracking

(firefox83 fixed)

RESOLVED FIXED
83 Branch
Tracking Status
firefox83 --- fixed

People

(Reporter: KrisWright, Assigned: gbrown)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

mach mochitest still runs with python 2 [1]. We want to convert all mach commands to python 3.

To do this, any dependencies of the command may need to be converted as well as the command itself.

[1] https://searchfox.org/mozilla-central/rev/9193635dca8cfdcb68f114306194ffc860456044/testing/mochitest/mach_commands.py

Assignee: nobody → hamzah18051
Status: NEW → ASSIGNED
Depends on: 1638963

Hi -- is there a status update on this work?

Flags: needinfo?(hamzah18051)
Duplicate of this bug: 1665436

Initial changes to allow mochitests to run in python 3. This works well on Linux,
and almost works on Android. A follow-up will complete the work on Android and
switch mach mochitest over to python 3.

Minor fix to remoteautomation.py: Increment stdoutlen before any type conversions,
to ensure that it accurately reflects the byte offset in the file.

With this last change, 'mach mochitest' appears to run correctly on Android with Python 3:
switch it over to Python 3.

Pushed by whole.grains@protonmail.com:
https://hg.mozilla.org/integration/autoland/rev/c6ad9a8b1152
Convert mochitest runtests.py to run with Python 3; r=bc
https://hg.mozilla.org/integration/autoland/rev/7cb6ce3ea604
Run 'mach mochitest' with Python 3; r=bc
Assignee: hamzah18051 → whole.grains
Flags: needinfo?(hamzah18051)
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch
Regressions: 1668097
Regressions: 1669251
You need to log in before you can comment on or make changes to this bug.