Closed Bug 1639415 Opened 4 months ago Closed 3 months ago

Clear Recent History window no longer appears in 77 beta

Categories

(Thunderbird :: General, defect, P1)

x86_64
All

Tracking

(thunderbird77 affected, thunderbird78+ fixed)

RESOLVED FIXED
Thunderbird 79.0
Tracking Status
thunderbird77 --- affected
thunderbird78 + fixed

People

(Reporter: mark_needham, Assigned: darktrojan)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:77.0) Gecko/20100101 Firefox/77.0

Steps to reproduce:

click on Tools > Clear Recent History or use Ctrl+Shift+Delete

Thunderbird 77.0b2 20200511021338
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:77.0) Gecko/20100101 Thunderbird/77.0

Actual results:

no Clear All History window appears

Expected results:

window showing Clear All History should appear as it does in previous versions eg 76b3

I can reproduce this on Ubuntu 18.04.4 LTS Linux using TB 77.0b3.

Works using 76.0b3, broken in 77.0b1.

Not sure if this is shared code with Firefox where it is activated from History > Clear Recent History and works in Fx 77.0b8.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → x86_64

NotSupportedError: ChromeUtils.registerWindowActor: 'Prompt' actor is already registered. ActorManagerParent.jsm:596
addActors resource://gre/modules/ActorManagerParent.jsm:596
_init resource://gre/modules/MailGlue.jsm:125
MailGlue resource://gre/modules/MailGlue.jsm:76
toSanitize chrome://messenger/content/mailCore.js:543
oncommand chrome://messenger/content/messenger.xhtml:1

Uncaught
Exception { name: "NS_ERROR_XPC_GS_RETURNED_FAILURE", message: "ServiceManager::GetService returned failure code:", result: 2153185302, filename: "chrome://messenger/content/mailCore.js", lineNumber: 543, columnNumber: 0, data: null, stack: "toSanitize@chrome://messenger/content/mailCore.js:543:6\noncommand@chrome://messenger/content/messenger.xhtml:1:1\n", location: XPCWrappedNative_NoHelper }
mailCore.js:543

Component: Untriaged → General
Keywords: regression
Priority: -- → P1

Related to the prompt stuff in bug 1640549?

Flags: needinfo?(geoff)

Can confirm still broken in released Thunderbird 78.0b1 - 20200611220825 and issue not shown in Beta Notes - Known Issues

I can't see any reason why there's an interface to open this dialog and nothing else (nsIMailGlue), so I got rid of it.

I also don't know why a new MailGlue object is created when .getService is called (this is the real problem here), but that's irrelevant after this patch.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Flags: needinfo?(geoff)
Attachment #9156617 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9156617 [details] [diff] [review]
1639415-sanitize-window-1.diff

Review of attachment 9156617 [details] [diff] [review]:
-----------------------------------------------------------------

Interesting... :) Very old cruft I suppose. r=mkmelin
Attachment #9156617 - Flags: review?(mkmelin+mozilla) → review+
Target Milestone: --- → Thunderbird 79.0

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/43b5533bb521
Fix "Clear Recent History" window. r=mkmelin DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Comment on attachment 9156617 [details] [diff] [review]
1639415-sanitize-window-1.diff

[Approval Request Comment]
Regression caused by (bug #): unknown
User impact if declined: clear recent history dialog unusable
Testing completed (on c-c, etc.): on c-c since yesterday
Risk to taking this patch (and alternatives if risky): minor
Attachment #9156617 - Flags: approval-comm-beta?
Comment on attachment 9156617 [details] [diff] [review]
1639415-sanitize-window-1.diff

Approved for beta
Attachment #9156617 - Flags: approval-comm-beta? → approval-comm-beta+

Can confirm FIXED in released Thunderbird 78.0b2 - 20200616103211

thank you all

You need to log in before you can comment on or make changes to this bug.