Cannot download files bigger than disk cache

RESOLVED DUPLICATE of bug 163841

Status

()

--
major
RESOLVED DUPLICATE of bug 163841
16 years ago
16 years ago

People

(Reporter: hanasaki, Assigned: gordon)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020812
100% reproducable
Lockup on dowload at ~50Meg via ftp or http through squid proxy on Debian Linux.
xkill was required to kill Mozilla.  ps -ef showed remaining mozilla-bin
processes that were then killed with 'kill [proc#]'

reference site for download
www.openoffice.org dowload v1.01 via http or ftp from the US or Japan
Windows 2000 version seems to download w/o incident.

Comment 1

16 years ago
Reporter : did you try with a 1.1 release candidate built on 18 august 2002 ?
(Reporter)

Comment 2

16 years ago
8/18/2002 was not tried.  Bug 163796 & 163797 are Critical Show Stoppers for me
so I rolled back to 8/12/2002 as below.
How much free space was in your /tmp partition?

Comment 4

16 years ago
Reporter: do you have a 50MB cache ? I noticed last week that I couldn't
download a new Mozilla vertsion, because I had set my cache to 5MB. I went away
when I went back to 50MB.

Could it be caused by the checkin for bug 81724 (not in 1.1b, only on the trunc)
? I'm not able to check with an older version (1.0 or 1.1) right now. But I
think it was no problem in older versions.

Comment 5

16 years ago
Confirming with Linux 2002-08-21-08 trunk.

Can't download files bigger than my disk cache setting (tried disk cache of
~15MB and ~50MB with a ~66MB file).

Changing summary
-> Networking: Cache
Assignee: bbaetz → gordon
Component: Networking: FTP → Networking: Cache
Keywords: regression
QA Contact: benc → tever
Summary: 50 meg download limit? http and ftp → Cannot download files bigger than disk cache
gordon is on vacation IIRC; darin, you touched the cache stuff recently, right
for gordon's patches?
(Reporter)

Comment 7

16 years ago
/tmp has over 3x the space required for the ~75meg download
The lockup still occurs w/ a disk cache of 90 Meg

Comment 8

16 years ago
Same problem here on NT4.
I would prefer if the file was saved directly to the selected download location.
(Like in Opera)
If cache and download location are on different partitions it takes extra time
to copy the file (with large files).

Comment 9

16 years ago

*** This bug has been marked as a duplicate of 163841 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 10

16 years ago
VERIFIED/dupe
QA Contact: tever → cacheqa
You need to log in before you can comment on or make changes to this bug.