Closed Bug 1640 Opened 24 years ago Closed 24 years ago

URL: Relative addressing yields http://promo1.html, munged page layout

Categories

(Core :: Networking, defect, P1)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 2110

People

(Reporter: elig, Assigned: gagan)

References

()

Details

* TITLE/SUMMARY
(www.netscape.com) Relative addressing yields http://promo1.html, munged page
layout

* STEPS TO REPRODUCE
0) Point the 11.24.98 build of viewer or xpviewer to www.netscape.com
1) Click on the "Netscape Netcenter banner" (Thanksgiving/promo banner currently
being used)

* RESULT
 - What happened

1. Viewer attempts to open http://promo1.html (and then www.promo1.html)
2. Content window ceases to be refreshed, although browser does not crash.

I assume this must've been reported before, but I can't find anything searching
for 'relative'.

* REGRESSION

 - Occurs On
        viewer.exe (11.24.98 build used)
        xpviewer.exe (11.24.98 build used)

 - Doesn't Occur On
        Communicator 4.5 for Win32 (RTM Complete build used on NT 4.0)


* CONFIGURATIONS TESTED

- Windows NT 4.0 SP 3, 96 MB RAM.
Note related bug 1651.
Assignee: rickg → rpotts
if you use the fully qualified URL (http://www/netscape.com/holiday/promot.html)
then the viewer works.
Assignee: rpotts → gagan
Re-assigned to gagan@netscape.com.

Gagan, is this a netlib bug?  Who should get this?
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → DUPLICATE
A lot of this relates to our handling of absolute/relative URLs. Bug # 2110
handles that for all cases, and so I am marking this as a duplicate of the same.

*** This bug has been marked as a duplicate of 2110 ***
*** Bug 1651 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
Verified duplicate (and that 2110 is a much more useful bug report for tracking
this.)
Component: Viewer App → Networking
Summary: Relative addressing yields http://promo1.html, munged page layout → URL: Relative addressing yields http://promo1.html, munged page layout
You need to log in before you can comment on or make changes to this bug.