Closed Bug 1640021 Opened 2 months ago Closed 1 month ago

Perma /html/cross-origin-embedder-policy/reporting-subresource-corp.https.html | [document] same-origin - promise_test: Unhandled rejection with value: object "TypeError: frame.contentWindow.ReportingObserver..." when Gecko 78 merges to Beta on 2020-06-01

Categories

(Core :: DOM: Core & HTML, defect)

defect

Tracking

()

VERIFIED FIXED
mozilla78
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 + verified

People

(Reporter: aryx, Assigned: tt)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

central-as-beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&selectedTaskRun=I2Lm0ugYRuK8qw_j6N8RtA-0&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=49ea038a588c25d575a555e74c45c2a23eb3fd57

Log: https://treeherder.mozilla.org/logviewer.html#?job_id=303230298&repo=try

/html/cross-origin-embedder-policy/reporting-subresource-corp.https.html | [document] same-origin - promise_test: Unhandled rejection with value: object "TypeError: frame.contentWindow.ReportingObserver is not a constructor"
and more

Blocks: 1613061
Blocks: 1563480
No longer blocks: 1613061

As we discuss on the slack, it might because ReportObserver is a Nightly only thing and the test case only check the length of reports from the report observer. So, it seems that it's reasonable the test case fails on Beta but pass on Nightly.

I will file a bug to investigate/verify the reason and track it in bug 1563480 and change the ini file to not block the merge.

Blocks: 1640145

I will provide a patch to change the expectation in the ini file.

No longer blocks: 1563480, 1640145
See Also: → 1640145
Assignee: nobody → ttung
Status: NEW → ASSIGNED

For some reasons, I couldn't bulid central-as-beta on my machine.

Here is the try for that and the patch: https://treeherder.mozilla.org/#/jobs?repo=try&revision=a922a7e7848d4aa3e4d31005e7c11d55e4574af7

I'm not sure if I need to do:

[TypeError: frame.contentWindow.ReportingObserver is not a constructor]
  expected:
    if not nightly_build: ERROR

(In reply to Tom Tung [:tt, :ttung] from comment #4)

For some reasons, I couldn't bulid central-as-beta on my machine.

The patch from bug 1639845 is needed to build on most platforms at the moment.

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #5)

(In reply to Tom Tung [:tt, :ttung] from comment #4)

For some reasons, I couldn't bulid central-as-beta on my machine.

The patch from bug 1639845 is needed to build on most platforms at the moment.

I see. Thanks!

Here is the try without bug 1639845: https://treeherder.mozilla.org/#/jobs?repo=try&revision=9e4fc5725195675e015f42148c05d800403db20d&selectedTaskRun=WBi9wPYQQGixeLq7zpG1JA-0 for version 283723.

We can see the test doesn't fail.

(In reply to Natalia Csoregi [:nataliaCs] from comment #6)

This is still happening https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&revision=0a2a522a5a5d64fa1bd762b819bcf5aa86d12484&searchStr=windows%2C7%2Cdebug%2Cweb%2Cplatform%2Ctests%2Ctest-windows7-32%2Fdebug-web-platform-tests-e10s-14%2Cw%28wpt14%29&selectedTaskRun=ZWOTgrGlRXuoTv-GaMFHIg-0

That was 283950. I think :aryx want to replace the nits for not nightly_build to release_or_beta in my patch, and thus he update the patch to 283950.
However, I updated the patch to 283723 after I had requested the review and he fixed the nits for the older version.

284046 should help the test to pass.

Pushed by ttung@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9155018d4978
Update the expectation for the test outside of Nightly since ReportingObserver is tied to Nightly; r=annevk
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
You need to log in before you can comment on or make changes to this bug.