Closed Bug 1640099 Opened 11 months ago Closed 10 months ago

Make sure blocking reasons is always set

Categories

(DevTools :: Netmonitor, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: Honza, Assigned: Honza)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This is a follow up for bug 1638313

The response listener is sending blocking reason to the client and the code should ensure that it's always set (otherwise the client wouldn't mark the request as blocked).

Honza

Assignee: nobody → odvarko
Status: NEW → ASSIGNED
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9036936c1908
imported patch always-set-reason.diff r=bomsy
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 78 → ---

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:Honza, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(odvarko)

I am closing this bug for now, since the patch introduces a regression bug 1640598

Honza

Status: REOPENED → RESOLVED
Closed: 11 months ago10 months ago
Flags: needinfo?(odvarko)
Resolution: --- → WONTFIX
See Also: → 1671147
You need to log in before you can comment on or make changes to this bug.