Closed Bug 1640904 Opened 3 months ago Closed 3 months ago

Perma devtools/server/tests/browser/browser_actor_error.js | Uncaught exception - at resource://devtools/shared/protocol/Front.js:323 when Gecko 78 merges to Beta on 2020-06-01

Categories

(DevTools :: General, defect)

defect

Tracking

(firefox-esr68 unaffected, firefox76 unaffected, firefox77 unaffected, firefox78+ verified)

VERIFIED FIXED
Firefox 78
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 + verified

People

(Reporter: aryx, Assigned: jdescottes)

References

(Regression)

Details

Attachments

(2 files)

central-as-beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=90fdf63cba3395f601470b7d26bb8fc39a323208&selectedTaskRun=V9472jcGT9qE0IKUtHwkKw-0

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=303764702&repo=try

[task 2020-05-26T13:22:21.603Z] 13:22:21 INFO - TEST-PASS | devtools/server/tests/browser/browser_actor_error.js | has a TestErrorsFront instance -
[task 2020-05-26T13:22:21.604Z] 13:22:21 INFO - TEST-PASS | devtools/server/tests/browser/browser_actor_error.js | -
[task 2020-05-26T13:22:21.604Z] 13:22:21 INFO - Buffered messages finished
[task 2020-05-26T13:22:21.604Z] 13:22:21 INFO - TEST-UNEXPECTED-FAIL | devtools/server/tests/browser/browser_actor_error.js | Uncaught exception - at resource://devtools/shared/protocol/Front.js:323 - Error: Protocol error (TypeError): this.a is undefined from: server0.conn12.testErrorsActor8 (chrome://mochitests/content/browser/devtools/server/tests/browser/test-errors-actor.js:39:5)
[task 2020-05-26T13:22:21.605Z] 13:22:21 INFO - Stack trace:
[task 2020-05-26T13:22:21.605Z] 13:22:21 INFO - onPacket/<@resource://devtools/shared/protocol/Front.js:323:31
[task 2020-05-26T13:22:21.606Z] 13:22:21 INFO - callFunctionWithAsyncStack@resource://devtools/shared/platform/stack.js:61:13
[task 2020-05-26T13:22:21.606Z] 13:22:21 INFO - onPacket@resource://devtools/shared/protocol/Front.js:308:31
[task 2020-05-26T13:22:21.607Z] 13:22:21 INFO - onPacket@resource://devtools/client/devtools-client.js:493:13
[task 2020-05-26T13:22:21.608Z] 13:22:21 INFO - send/<@resource://devtools/shared/transport/local-transport.js:68:25
[task 2020-05-26T13:22:21.608Z] 13:22:21 INFO - exports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:103:22
[task 2020-05-26T13:22:21.608Z] 13:22:21 INFO - callFunctionWithAsyncStack@resource://devtools/shared/platform/stack.js:61:13
[task 2020-05-26T13:22:21.608Z] 13:22:21 INFO - executor@resource://devtools/shared/DevToolsUtils.js:49:35
[task 2020-05-26T13:22:21.609Z] 13:22:21 INFO - exports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:103:22
[task 2020-05-26T13:22:21.609Z] 13:22:21 INFO - Leaving test bound test_protocoljs_actor
[task 2020-05-26T13:22:21.609Z] 13:22:21 INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-05-26T13:22:21.609Z] 13:22:21 INFO - TEST-UNEXPECTED-FAIL | devtools/server/tests/browser/browser_actor_error.js | The main process DevToolsServer has no pending connection when the test ends -

Flags: needinfo?(jdescottes)

The exception used in this test has different formats depending on the channel.

Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Flags: needinfo?(jdescottes)
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1a878a7a1b14
Force property_error_message_fix in browser_actor_error.js r=nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78

Looks like we can't flip the preference at runtime...

Flags: needinfo?(jdescottes)
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b30bdedb0bdf
Do not assert specific error message in browser_actor_error.js r=nchevobbe
Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
You need to log in before you can comment on or make changes to this bug.