[DOGFOOD]mozilla.exe crashes if there's no profile directory.

VERIFIED FIXED in M11

Status

Core Graveyard
Profile: BackEnd
P3
normal
VERIFIED FIXED
19 years ago
2 years ago

People

(Reporter: Sean Su, Assigned: racham)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

19 years ago
This happens when there is a mozregistry.dat, but no profile directory to go
with it.

Deleting the mozregistry.dat launches the profile manager and then the browser
comes up fine.

Updated

19 years ago
Assignee: selmer → racham

Comment 1

19 years ago
Bhuvan, I didn't find any duplicates of this in the open bugs.  I had thought
this was fixed, but maybe recent changes broke it again.  Steve

Comment 2

19 years ago
Dogfood Candidate

Updated

19 years ago
Summary: mozilla.exe crashes if there's no profile directory. → [DOGFOOD]mozilla.exe crashes if there's no profile directory.

Updated

19 years ago
Whiteboard: [PDT+]

Comment 3

19 years ago
If there is a mozregistry.dat file but the profile directory has been deleted,
the profiles in the mozregistry.dat will be listed in profile manager window. If
you select one, you will exit - since there are no profile files associated with
the entry
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11
(Assignee)

Comment 4

19 years ago
accepting the bug.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
The crash occurred in the past, as the profile directory was deleted and
app couldn't find prefs file.

This is Fixed. Code has been added to recreate the entire directory structure
that is lost. The directory path is obtained from the registry. Contents of the
defaults/profile folder gets copied into the newly created folder.
(Assignee)

Comment 6

19 years ago
*** Bug 14941 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

19 years ago
*** Bug 12107 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
build 1999102908

Updated

19 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 9

19 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.