IMAP: advanced search doesn't work for some zennkaku-katakanas

RESOLVED DUPLICATE of bug 243625

Status

MailNews Core
Internationalization
RESOLVED DUPLICATE of bug 243625
15 years ago
9 years ago

People

(Reporter: Kasumi, Assigned: nhottanscp)

Tracking

({qawanted})

Trunk
x86
Windows XP
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
tested on 2002-08-21-08-1.0
Win XP Pro. JA + SP1 Beta1

1. Set ISO-2022-JP to Mail&Newsgroups/Message Display
2. Launc Mail&Newsgroups
3. Click Advanced button in Search bar
4. Set Subject contents "do"(8368) in zennkaku- katakana
5. Click Search button
6. You will see that target "do" is ignored
   All messages in specified folder are displayed in result list
   "go"(8353), "bu"(8375), "zu"(8359), "ze"(835B)

Comment 1

15 years ago
Kasumi, how is that bug different from bug# 163793? Thanks.
(Reporter)

Comment 2

15 years ago
These characters don't work.
But only JA build, "za"(8355) also. 
I tested few xx68, xx53, xx75, xx59, xx5B s. No problem.
Those character works perfectly on Search toolbar.
Keywords: nsbeta1

Comment 3

15 years ago
Kasumi, when you say 
<These characters don't work.But only JA build, "za"(8355) also.> you mean that
this work in US build? Is this bug for a localized build?  
(Assignee)

Comment 4

15 years ago
kasumi, is this for IMAP?
Status: NEW → ASSIGNED
(Reporter)

Comment 5

15 years ago
Answer to #3.
"za" doesn't work on US and JA both.
This happenes on US build noy localized build.

Answer to #4.
Yes. 

Comment 6

15 years ago
qa contact over to Kasumi
QA Contact: marina → kasumi

Comment 7

15 years ago
changing qa contact
QA Contact: kasumi → marina
(Assignee)

Comment 8

15 years ago
Looks like IMAP only but I cannot find info about local mail, adding 'qawanted'.
Keywords: qawanted

Updated

15 years ago
Summary: advanced search doesn't work for some zennkaku-katakanas → IMAP: advanced search doesn't work for some zennkaku-katakanas

Comment 9

15 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 10

14 years ago
Mozilla doesn't follow the IMAP syntax. More precisely, it sends 
quoted chars that contain characters outside the range 0x01 - 0x7f,
forcing the IMAP servers to return a parsing error. See the syntax below:

QUOTED_CHAR     ::= <any TEXT_CHAR except quoted_specials> / "\" quoted_specials
TEXT_CHAR       ::= <any CHAR except CR and LF>
CHAR            ::= <any 7-bit US-ASCII character except NUL, 0x01 - 0x7f>

A fix to this bug;
Send literals instead. That is, command 

Mozilla: 1 search text "bogus char follows: '0x80'"CRLF
Server: 1 BAD bogus attribute...

should become:

Mozilla: 1 search text {21}CRLF
Server: +CRLF
Mozilla: bogus char follows: '0x80'CRLF

Comment 11

14 years ago
Please take a look at bug# 243625 
Same bug?
Product: MailNews → Core

Comment 12

11 years ago
marking dup of fixed bug, thx.

*** This bug has been marked as a duplicate of 243625 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.