Closed Bug 1641600 Opened 1 month ago Closed 1 month ago

Re-enable RTX with pref that disables it for broken sites

Categories

(Core :: WebRTC: Signaling, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
mozilla79
Tracking Status
firefox79 --- fixed

People

(Reporter: dminor, Assigned: dminor)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

RTX currently breaks Google Meet (See Bug 1638758). We'd like to enable RTX for sites where it works properly, so we'll need to add a pref to control which sites are allowed to use RTX. Before we can turn it back on, we need to fix Bug 1640697.

Blocks: 1642419
Attachment #9153420 - Attachment description: Bug 1641600 - Check RTX blacklist pref in PeerConnectionImpl; r=bwc! → Bug 1641600 - Check RTX blocklist pref in PeerConnectionImpl; r=bwc!
Attachment #9153421 - Attachment description: Bug 1641600 - Re-enable rtx and add *.google.com to blacklist; r=bwc! → Bug 1641600 - Re-enable rtx and add *.google.com to blocklist; r=bwc!
Blocks: 1643155
Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/86c2932e66d3
Add SetRtxIsAllowed method to JsepTrack and JsepSession; r=bwc
https://hg.mozilla.org/integration/autoland/rev/249782af96bb
Check RTX blocklist pref in PeerConnectionImpl; r=bwc
https://hg.mozilla.org/integration/autoland/rev/41a85b7d3e5e
Re-enable rtx and add *.google.com to blocklist; r=bwc

Yay, yet another backout because tests don't run on Android hardware on try by default.

Flags: needinfo?(dminor)

With RTX and transport-cc enabled, it is possible to send padding packets prior
to any media being sent (see comments in RTPSender::SendPadData). But padding
bytes are counted separate from payload bytes and so do not show up in
bytesSent, which means that is possible that we've sent packets, but not bytes,
as far as the stats are concerned. This leads to frequent intermittent failures
while running tests on Android hardware.

Depends on D77815

Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b6cc21d51827
Add SetRtxIsAllowed method to JsepTrack and JsepSession; r=bwc
https://hg.mozilla.org/integration/autoland/rev/173f863893da
Check RTX blocklist pref in PeerConnectionImpl; r=bwc
https://hg.mozilla.org/integration/autoland/rev/edcc03ec3ea0
Re-enable rtx and add *.google.com to blocklist; r=bwc
https://hg.mozilla.org/integration/autoland/rev/297d2efe3bb8
Remove check that bytesSent >= packetsSent in pc.js; r=ng
Regressions: 1644577
You need to log in before you can comment on or make changes to this bug.