Closed Bug 1642219 Opened 3 years ago Closed 2 years ago

Add "Add-ons Support" to Thunderbird add-ons manager

Categories

(Thunderbird :: Add-Ons: General, defect, P1)

Tracking

(thunderbird_esr78? verified, thunderbird86 verified, thunderbird87? affected)

VERIFIED FIXED
87 Branch
Tracking Status
thunderbird_esr78 ? verified
thunderbird86 --- verified
thunderbird87 ? affected

People

(Reporter: wsmwk, Assigned: TbSync)

References

Details

Attachments

(1 file)

Firefox has this - for some reason it is missing in Thunderbird. It would be good to have this for version 78. I assume it requires strings. NI Magnus to assign. NI Alex in case he has any concerns.

We need to point it somewhere. https://support.mozilla.org/en-US/kb/thunderbird-add-ons-frequently-asked-questions should be good enough for now. Although that KB cound stand to be improved.

Firefox's goes to https://support.mozilla.org/en-US/products/firefox/manage-preferences-and-add-ons-firefox/install-and-manage-add-ons?as=u&utm_source=inproduct

Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(alessandro)
See Also: → 1642220
Flags: needinfo?(mkmelin+mozilla)

Links to https://support.thunderbird.net/en-US/thunderbird/20200601150546/addons-help
That's from app.support.baseURL.

So if someone creates a page at the suitable URL we can unhide it.

Priority: -- → P1

I can take care of this if you want.
All agree to point that button to the URL Ways proposed?
https://support.mozilla.org/en-US/kb/thunderbird-add-ons-frequently-asked-questions

Flags: needinfo?(alessandro)

To avoid needless code to handle what url is used, we should create the corresponding url/redirect as firefox.
I think firefox also redirect - one ends up at https://support.mozilla.org/en-US/products/firefox/manage-preferences-and-add-ons-firefox/install-and-manage-add-ons?as=u&utm_source=inproduct

BTW, https://support.mozilla.org/en-US/kb/thunderbird-add-ons-frequently-asked-questions links to MDN add-on development at the bottom of the page. That should go to DTN.)

Assignee: nobody → alessandro
Status: NEW → ASSIGNED

John and I discussed this yesterday in matrix

John, since you've been doing some great work on the Add-ons Manager, do you thin you would have time to take care of this?

Flags: needinfo?(john)

sure, just assign me.

Flags: needinfo?(john)
Assignee: alessandro → john

The pull request to add the redirect has been merged, so we can unhide the button now. It will take another day or two before the new setting becomes active.

Attachment #9201873 - Flags: review?(alessandro)
Comment on attachment 9201873 [details] [diff] [review]
bug1642219_unhide_addons_support_button.patch

Review of attachment 9201873 [details] [diff] [review]:
-----------------------------------------------------------------

Nice, thanks. r=aleca
Attachment #9201873 - Flags: review?(alessandro) → review+

The redirect is active. We can get this landed.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/c34f619b584b
Unhide the Add-ons Support button. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch

Comment on attachment 9201873 [details] [diff] [review]
bug1642219_unhide_addons_support_button.patch

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined:
No Support Link

Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):
Zero to none.

Attachment #9201873 - Flags: approval-comm-esr78?
Attachment #9201873 - Flags: approval-comm-beta?

Comment on attachment 9201873 [details] [diff] [review]
bug1642219_unhide_addons_support_button.patch

[Triage Comment]
Approved for beta

Attachment #9201873 - Flags: approval-comm-beta? → approval-comm-beta+

TB 86.0b3 on Windows 10

Status: RESOLVED → VERIFIED

Comment on attachment 9201873 [details] [diff] [review]
bug1642219_unhide_addons_support_button.patch

[Triage Comment]
Approved for esr78

Attachment #9201873 - Flags: approval-comm-esr78? → approval-comm-esr78+

Works for me in my tests of the 78.8.0 release candidate on Fedora 33 Workstation and Windows 10.

You need to log in before you can comment on or make changes to this bug.