Closed Bug 1642245 Opened 11 months ago Closed 10 months ago

Give a non-localised version of DDG to all locales

Categories

(SeaMonkey :: Search, defect)

defect

Tracking

(seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.76
Tracking Status
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

(Whiteboard: SM2.53.3)

Attachments

(1 file, 1 obsolete file)

Localised versions of DDG override any setting user may have configured for region so, we should also ship a non-localised version in the list of available search engines.

Attached patch non-localised DDG (obsolete) — Splinter Review

[Approval Request Comment]
Regression caused by (bug #): 1636756
User impact if declined: Region setting is ignored for first search
Testing completed (on m-c, etc.): 2.53.3
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none

Should we create a ddg-en-US and also ship ddg-all with en-US?
ka doesn't have a localised ddg (yet).

Attachment #9153039 - Flags: review?(frgrahl)
Attachment #9153039 - Flags: approval-comm-release?
Attachment #9153039 - Flags: approval-comm-esr60?
Depends on: 1640775
Attached patch Global DDGSplinter Review

Changes since last patch:

  • Now an en-US DDG search engine
  • Description says Global rather than All for the non-localised version
Attachment #9153039 - Attachment is obsolete: true
Attachment #9153039 - Flags: review?(frgrahl)
Attachment #9153039 - Flags: approval-comm-release?
Attachment #9153039 - Flags: approval-comm-esr60?
Attachment #9153252 - Flags: review?(frgrahl)
Attachment #9153252 - Flags: approval-comm-release?
Attachment #9153252 - Flags: approval-comm-esr60?
Comment on attachment 9153252 [details] [diff] [review]
Global DDG

LGTM
Attachment #9153252 - Flags: review?(frgrahl)
Attachment #9153252 - Flags: review+
Attachment #9153252 - Flags: approval-comm-release?
Attachment #9153252 - Flags: approval-comm-release+
Attachment #9153252 - Flags: approval-comm-esr60?
Attachment #9153252 - Flags: approval-comm-esr60+
Whiteboard: SM2.53.3

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/5578dcf8959f
Give a non-localised version of DDG to all locales. r=frg

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.