Closed Bug 1642869 Opened 1 month ago Closed 1 month ago

layout/generic/test/test_page_scroll_with_fixed_pos.html fails with apz.allow_zooming = true

Categories

(Core :: Layout: Scrolling and Overflow, defect)

defect

Tracking

()

RESOLVED FIXED
mozilla79
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 --- disabled
firefox79 --- fixed

People

(Reporter: tnikkel, Assigned: tnikkel)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Caused by bug 1639448.

Blocks: 1621740

So we can preserve the scrolling behaviour that takes into account fixed "headers" and "footers".

Assignee: nobody → tnikkel
Status: NEW → ASSIGNED
Component: Panning and Zooming → Layout: Scrolling and Overflow
Attachment #9153713 - Attachment description: Bug 1642869. Check if the visual viewport differs from the layout viewport in ScrollFrameHelper::GetPageScrollAmount. r?kats → Bug 1642869. Check if the visual viewport differs from the layout viewport in ScrollFrameHelper::GetPageScrollAmount. r=kats
Pushed by tnikkel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a934a2435d2a
Check if the visual viewport differs from the layout viewport in ScrollFrameHelper::GetPageScrollAmount. r=kats
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
You need to log in before you can comment on or make changes to this bug.