Closed Bug 1639448 Opened 3 months ago Closed 3 months ago

clicking on scrollbar track after pinch zoom on scroll frame without overflow scrolls too far

Categories

(Core :: Panning and Zooming, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox76 --- disabled
firefox77 --- disabled
firefox78 --- fixed

People

(Reporter: tnikkel, Assigned: tnikkel)

References

Details

Attachments

(1 file)

No description provided.

We want to use a page scroll amount based on the visual viewport size.

The extra complications we have for not scrolling too far if there are fixed/sticky position things are quite hard to do properly with a visual viewport (I tried). I think there is far less user expectation of it working if a visual viewport is set. If we get complaints we can look into it.

Assignee: nobody → tnikkel
Status: NEW → ASSIGNED

This bug is currently impossible to see due to bug 1639450. However, I have a hacky fix for bug 1639450 locally which exposes this bug. Bug 1639450 is more involved so I'm going to land this fix since I have it, it should be able to shake out any possible regressions caused by it sooner.

Severity: -- → S3
Priority: -- → P3
Pushed by tnikkel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2d00a1a6495c
When a visual viewport is set the page scroll amount for a scroll frame is incorrect. r=kats
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Regressions: 1642869
You need to log in before you can comment on or make changes to this bug.