Closed Bug 1643058 Opened 8 months ago Closed 7 months ago

webrtc web-platform-tests need a cleanup

Categories

(Core :: WebRTC: Signaling, task, P2)

task

Tracking

()

RESOLVED FIXED
mozilla79
Tracking Status
firefox79 --- fixed

People

(Reporter: bwc, Assigned: bwc)

References

Details

Attachments

(8 files)

There are lots of disabled webrtc wpt, with no bug numbers in the ini files. The ini files need to be evaluated, tests re-enabled if possible, and bug links added if not.

Seeing lots of instances of bug 1641788 in that push.

Depends on: 1641788
See Also: → 1643947

Push without fuzzy --full: Only seeing known intermittents. https://treeherder.mozilla.org/#/jobs?repo=try&revision=fd392d1975c6e8ac19e8d77cc984d24fb4ae2ac9

Push with fuzzy --full: Mostly known intermittents here, but there are some failures on android that I don't see in bugzilla anywhere: https://treeherder.mozilla.org/#/jobs?repo=try&revision=d1edc0bf860fc9a0e8bc43812e5b31c7e777e5a1

Here's a push on the base revision to check out those Android failures: https://treeherder.mozilla.org/#/jobs?repo=try&revision=32debcb7d02700c2c724ac230492a103488e42d6

The failures on fuzzy --full android happen on the base revision too. So, try looks good. Let's see if that holds up after a rebase!

Depends on D79528

Depends on D79529

Depends on D79530

Try looks good.

Lots of bug 1645663 in those pushes. Also seeing some intermittents that bug 1645219 fixes.

Hit merge conflicts when trying to land, so here are some more try pushes!

https://treeherder.mozilla.org/#/jobs?repo=try&revision=0dcb3cba323c512c5930e8368fe9c16d94952a61
See Also: → 1645663
Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e6edf6df8183
Clean up ini files. r=jib
https://hg.mozilla.org/integration/autoland/rev/c4f71ccf6934
Try to work around bug 1641237 by adding some restart-after on longer tests. r=jib
https://hg.mozilla.org/integration/autoland/rev/7d90312af10f
Clean up PeerConnections in these tests. r=jib
https://hg.mozilla.org/integration/autoland/rev/12c6d279b173
Mark these tests as long, because they do ICE. r=jib
https://hg.mozilla.org/integration/autoland/rev/fcc0942206d9
Timestamp mDNS lookups. r=dminor
https://hg.mozilla.org/integration/autoland/rev/6dd69c93d9e2
Add a restart-after to avoid timeouts in the next test on win 7 debug. r=jib
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/24323 for changes under testing/web-platform/tests
Flags: needinfo?(docfaraday)
Upstream PR was closed without merging

Yeah, the merge was bad. Trying again...

Flags: needinfo?(docfaraday)
Blocks: 1648199

Depends on D80947

Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ebad65f70e2d
Clean up ini files. r=jib
https://hg.mozilla.org/integration/autoland/rev/b32e18c3d542
Try to work around bug 1641237 by adding some restart-after on longer tests. r=jib
https://hg.mozilla.org/integration/autoland/rev/4767df198c29
Clean up PeerConnections in these tests. r=jib
https://hg.mozilla.org/integration/autoland/rev/cf062b9c00b4
Mark these tests as long, because they do ICE. r=jib
https://hg.mozilla.org/integration/autoland/rev/9c677d996512
Timestamp mDNS lookups. r=dminor
https://hg.mozilla.org/integration/autoland/rev/141ade17eb3c
Add a restart-after to avoid timeouts in the next test on win 7 debug. r=jib
https://hg.mozilla.org/integration/autoland/rev/36f54439ad2e
Make these tests fail instead of timing out if ICE fails. r=jib
https://hg.mozilla.org/integration/autoland/rev/78d7201bf2a0
Add bug link for this failure. r=jib
Flags: needinfo?(docfaraday)

/webrtc/RTCPeerConnection-createDataChannel.html seems to be having unexpected errors on Chrome, but the only change there was marking the test as long.
/webrtc/RTCPeerConnection-setRemoteDescription-tracks.https.html is the same story.
/webrtc/datachannel-emptystring.html just had some necessary cleanup added.
/webrtc/no-media-call.html just had some necessary cleanup added.

Looks like Chrome needs to update their test expectations.

Flags: needinfo?(docfaraday)
Upstream PR merged by jgraham
Duplicate of this bug: 1643947
You need to log in before you can comment on or make changes to this bug.