Closed Bug 1645663 Opened 8 months ago Closed 7 months ago

Intermittent TEST-UNEXPECTED-TIMEOUT | /webrtc/RTCRtpSender-replaceTrack.https.html | ReplaceTrack transmits the new track not the old track - Test timed out

Categories

(Core :: WebRTC, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla79
Tracking Status
firefox79 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: bwc)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell disable-recommended])

Attachments

(2 files)

Filed by: rmaries [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=306275585&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/B9h62x6IS1KP4K8vZVwoiw/runs/0/artifacts/public/logs/live_backing.log


[task 2020-06-14T08:34:15.127Z] 08:34:15 INFO - TEST-START | /webrtc/RTCRtpSender-replaceTrack.https.html
[task 2020-06-14T08:34:45.811Z] 08:34:45 INFO - TEST-PASS | /webrtc/RTCRtpSender-replaceTrack.https.html | Calling replaceTrack on sender with similar track and and set to session description should resolve with sender.track set to new track
[task 2020-06-14T08:34:45.811Z] 08:34:45 INFO - TEST-UNEXPECTED-TIMEOUT | /webrtc/RTCRtpSender-replaceTrack.https.html | ReplaceTrack transmits the new track not the old track - Test timed out
[task 2020-06-14T08:34:45.812Z] 08:34:45 INFO - TEST-UNEXPECTED-TIMEOUT | /webrtc/RTCRtpSender-replaceTrack.https.html | expected OK
[task 2020-06-14T08:34:45.812Z] 08:34:45 INFO - TEST-INFO took 30687ms
[task 2020-06-14T08:34:45.851Z] 08:34:45 INFO - PID 1404 | 1592123685821 Marionette INFO Stopped listening on port 53295

Looks like this test started doing ICE recently, so needs to be marked "long".

Assignee: nobody → docfaraday
Flags: needinfo?(aryx.bugmail)

While try looks pretty horrible, that appears to be pre-existing intermittents. This test has stopped timing out.

Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cf10292e90ab
Mark this test as long because it does ICE. r=jib
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/24238 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
Upstream PR merged by moz-wptsync-bot

This appears to be a case that only happens when the webrtc wpt are run in the entire suite; running just the webrtc wpt (see comment 6) works ok. Since this is only win7 debug, I suspect the failures are being caused by the same thing as bug 1643947.

Flags: needinfo?(docfaraday)
See Also: → 1643947

The patches on bug 1643058 seem to improve this somewhat, probably one of the restart-afters that were added.

See Also: → 1643058
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/5c0784fac661
adjust expectations for RTCRtpSender-replaceTrack.https.html on Windows 7 debug. r=test-only DONTBUILD CLOSED TREE

Argh! Bug 1643058 is rotted again! Please stop touching these files until bug 1643058 is landed.

Status: REOPENED → RESOLVED
Closed: 7 months ago7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
Regressions: 1648313

This test has been re-enabled by bug 1643058, and seems to be behaving itself now, probably due to the restart-after that was added.

You need to log in before you can comment on or make changes to this bug.