Closed Bug 1643154 Opened 1 month ago Closed 1 month ago

Migrate browser.urlbar.openViewOnFocus to browser.urlbar.suggest.topsites

Categories

(Firefox :: Address Bar, task)

task
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 79
Iteration:
79.1 - June 1 - June 14
Tracking Status
firefox78 --- verified
firefox79 --- verified

People

(Reporter: harry, Assigned: harry)

References

Details

Attachments

(1 file)

Some users disabled the openViewOnFocus pref to disable the address bar's Top Sites feature. We introduced a new pref for this in bug 1627858. We should try to migrate the prefs, if we can still uplift to 78.

I hope such migration wouldn't revert any other behaviour provided by openViewOnFocus.

I don't like top sites, but I also don't want my address bar to open any popups until I start typing.

Heck, I run a userChrome.css fix to prevent it from zooming/expanding (as well as revert many of the "innovations" of the last few years back to a more Chrome-like UI) and, if that stops working, I'll be in the market for a new browser after sticking with Mozilla since Mozilla Suite 0.9 and putting up with how something in my extension loadout causes some sites to freeze up my chrome process for nearly a minute, consuming 100% of a CPU core.

(In reply to Stephan Sokolow from comment #2)

I hope such migration wouldn't revert any other behaviour provided by openViewOnFocus.

openViewOnFocus was never intended as a user-facing preference, it's in about:config and there's no guarantee those hidden prefs are stable.
Reopening left behind searches is part of the design experience and can't be disabled through a pref. This is already true in Firefox 78, regardless of this migration.

putting up with how something in my extension loadout causes some sites to freeze up my chrome process for nearly a minute, consuming 100% of a CPU core.

If you wish you can get a profile with https://profiler.firefox.com/ and file a bug with the resulting profile, it should be possible to figure out what's hanging.

Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7f604ae7de5a
Migrate browser.urlbar.openViewOnFocus to browser.urlbar.suggest.topsites. r=mak
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79

uplift reminder

Flags: needinfo?(htwyford)

Comment on attachment 9153972 [details]
Bug 1643154 - Migrate browser.urlbar.openViewOnFocus to browser.urlbar.suggest.topsites. r?mak

Beta/Release Uplift Approval Request

  • User impact if declined: This patch migrates a pref that changed its name in 78. The pref appeared to be widely used among power users, which is why we introduced a new about:preferences option for it. Since the pref was in wide use, allowing this pref to migrate will avert a number of support requests and upset users.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Set the pref browser.urlbar.openViewOnFocus to false in 78 Nightly. Observe that the pref browser.urlbar.suggest.topsites has the value true.
  1. Upgrade to 78 Beta.
  2. Observe that the pref browser.urlbar.suggest.topsites has the value false.
  3. Observe that in about:preferences > Privacy & Security > Address bar, the Top sites option is not checked.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The patch uses the standard way to migrate a pref. If the migration goes wrong, the pref only controls a UI feature and would not severely impact the user's experience.
  • String changes made/needed:
Flags: needinfo?(htwyford)
Attachment #9153972 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9153972 [details]
Bug 1643154 - Migrate browser.urlbar.openViewOnFocus to browser.urlbar.suggest.topsites. r?mak

approved for 78.0b5

Attachment #9153972 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Verified - Fixed in latest Nightly 79.0a1 (2020-06-09) and Beta 78.0b5 (build id: 20200609215727). The browser.urlbar.suggest.topsites pref is true by default after upgrading from nightly 78 to beta 78.0b5 and the top sites option is unchecked.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.