Closed Bug 1643253 Opened 4 months ago Closed 3 months ago

Collect more telemetry data about the Application panel usage

Categories

(DevTools :: Application Panel, task, P3)

task

Tracking

(firefox80 fixed)

RESOLVED FIXED
Firefox 80
Tracking Status
firefox80 --- fixed

People

(Reporter: Honza, Assigned: ladybenko)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Basic telemetry about the Application panel usage (panel open/close) where added in bug 1451734.

This is a follow up bug that should be used to introduce additional telemetry for:

  • Navigation in the side bar (Service Workers/Manifest)
  • Clicking on Debug/Start/Unregister buttons

Honza

Also note that clicking on the Debug button should use an existing enter event's start_state key

https://searchfox.org/mozilla-central/rev/7cadba1d8b8feaec4615f5bb98aac4b8a719793c/toolkit/components/telemetry/Events.yaml#1247

Honza

Assignee: nobody → balbeza
Status: NEW → ASSIGNED
Attached file request.md
Attachment #9161580 - Flags: data-review?(tdsmith)
Comment on attachment 9161580 [details]
request.md

r+, thanks!

1) Is there or will there be **documentation** that describes the schema for the ultimate data set in a public, complete, and accurate way? Click the documentation link provided in Q6 and ensure it is publicly accessible and does or will contain documentation for the data collection.

Yes, in Events.yaml and the probe dictionary.

2) Is there a control mechanism that allows the user to turn the data collection on and off? (Note, for data collection not needed for security purposes, Mozilla provides such a control mechanism) Provide details as to the control mechanism available.

Yes, the Firefox telemetry opt-out.

3) If the request is for permanent data collection, is there someone who will monitor the data over time?

Yes, Harald's on the hook as usual.

4) Using the **[category system of data types](https://wiki.mozilla.org/Firefox/Data_Collection)** on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 2, technical data.

5) Is the data collection request for default-on or default-off?

Default-on.

6) Does the instrumentation include the addition of **any *new* identifiers** (whether anonymous or otherwise; e.g., username, random IDs, etc.  See the appendix for more details)?

No.

7) Is the data collection covered by the existing Firefox privacy notice?

Yes.

8) Does there need to be a check-in in the future to determine whether to renew the data? (Yes/No) 

No, permanent collection.

9) Does the data collection use a third-party collection tool?

No.
Attachment #9161580 - Flags: data-review?(tdsmith) → data-review+
Duplicate of this bug: 1597269
Pushed by balbeza@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f63b52ffc53a
Part 1: Add telemetry middleware to record application panel events r=jdescottes,janerik
https://hg.mozilla.org/integration/autoland/rev/bb3999a4e5cf
Part 2: Add telemetry mochitests r=jdescottes,Honza
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 80
Regressions: 1652828
You need to log in before you can comment on or make changes to this bug.