Closed Bug 1652828 Opened 2 months ago Closed 2 months ago

High frequency devtools/client/application/test/browser/browser_application_panel_telemetry-workers.js | Test timed out -

Categories

(DevTools :: General, defect, P5)

defect

Tracking

(firefox-esr68 unaffected, firefox-esr78 unaffected, firefox78 unaffected, firefox79 unaffected, firefox80 fixed)

RESOLVED FIXED
Firefox 80
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox78 --- unaffected
firefox79 --- unaffected
firefox80 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: ladybenko)

References

(Regressed 2 open bugs, Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(2 files)

Filed by: malexandru [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=309763314&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/DZHVEi7fSga4Ff5UDOpw-A/runs/0/artifacts/public/logs/live_backing.log


[task 2020-07-14T17:32:53.700Z] 17:32:53     INFO - TEST-START | devtools/client/application/test/browser/browser_application_panel_telemetry-workers.js
[task 2020-07-14T17:32:53.801Z] 17:32:53     INFO - GECKO(1274) | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-07-14T17:32:54.237Z] 17:32:54     INFO - GECKO(1274) | Empty service worker registered
[task 2020-07-14T17:32:54.359Z] 17:32:54     INFO - GECKO(1274) | [CodeCoverage] Setting handlers for process 1872.
[task 2020-07-14T17:32:58.022Z] 17:32:58     INFO - GECKO(1274) | Empty service worker registered
[task 2020-07-14T17:33:38.722Z] 17:33:38     INFO - TEST-INFO | started process screentopng
[task 2020-07-14T17:33:38.940Z] 17:33:38     INFO - TEST-INFO | screentopng: exit 0
[task 2020-07-14T17:33:38.940Z] 17:33:38     INFO - Buffered messages logged at 17:32:53
[task 2020-07-14T17:33:38.941Z] 17:33:38     INFO - Entering test bound 
[task 2020-07-14T17:33:38.941Z] 17:33:38     INFO - Adding a new tab with URL: http://example.com/browser/devtools/client/application/test/browser/resources/service-workers/simple.html
[task 2020-07-14T17:33:38.941Z] 17:33:38     INFO - Buffered messages logged at 17:32:54
[task 2020-07-14T17:33:38.942Z] 17:33:38     INFO - Tab added and finished loading
[task 2020-07-14T17:33:38.942Z] 17:33:38     INFO - Buffered messages logged at 17:32:55
[task 2020-07-14T17:33:38.942Z] 17:33:38     INFO - Selecting application page: service-workers
[task 2020-07-14T17:33:38.942Z] 17:33:38     INFO - TEST-PASS | devtools/client/application/test/browser/browser_application_panel_telemetry-workers.js | No events have been logged for the main process - 
[task 2020-07-14T17:33:38.942Z] 17:33:38     INFO - Wait until the service worker appears in the application panel
[task 2020-07-14T17:33:38.943Z] 17:33:38     INFO - Wait until the unregister button is displayed for the service worker
[task 2020-07-14T17:33:38.943Z] 17:33:38     INFO - Click the unregister button
[task 2020-07-14T17:33:38.943Z] 17:33:38     INFO - Check telemetry event
[task 2020-07-14T17:33:38.943Z] 17:33:38     INFO - TEST-PASS | devtools/client/application/test/browser/browser_application_panel_telemetry-workers.js | There was only 1 event logged - 
[task 2020-07-14T17:33:38.943Z] 17:33:38     INFO - TEST-PASS | devtools/client/application/test/browser/browser_application_panel_telemetry-workers.js | There is a valid session_id in the event - 
[task 2020-07-14T17:33:38.943Z] 17:33:38     INFO - TEST-PASS | devtools/client/application/test/browser/browser_application_panel_telemetry-workers.js | {"method":"unregister_worker","session_id":"105642"} deepEqual {"method":"unregister_worker","session_id":"105642"} - 
[task 2020-07-14T17:33:38.944Z] 17:33:38     INFO - Closing the tab.
[task 2020-07-14T17:33:38.944Z] 17:33:38     INFO - Leaving test bound 
[task 2020-07-14T17:33:38.944Z] 17:33:38     INFO - Entering test bound 
[task 2020-07-14T17:33:38.944Z] 17:33:38     INFO - Set a low service worker idle timeout
[task 2020-07-14T17:33:38.944Z] 17:33:38     INFO - Buffered messages logged at 17:32:57
[task 2020-07-14T17:33:38.945Z] 17:33:38     INFO - Adding a new tab with URL: http://example.com/browser/devtools/client/application/test/browser/resources/service-workers/simple.html
[task 2020-07-14T17:33:38.946Z] 17:33:38     INFO - Tab added and finished loading
[task 2020-07-14T17:33:38.947Z] 17:33:38     INFO - Buffered messages logged at 17:32:59
[task 2020-07-14T17:33:38.947Z] 17:33:38     INFO - Selecting application page: service-workers
[task 2020-07-14T17:33:38.948Z] 17:33:38     INFO - Wait until the registration appears on the window
[task 2020-07-14T17:33:38.948Z] 17:33:38     INFO - TEST-PASS | devtools/client/application/test/browser/browser_application_panel_telemetry-workers.js | No events have been logged for the main process - 
[task 2020-07-14T17:33:38.949Z] 17:33:38     INFO - Wait until the service worker appears in the application panel
[task 2020-07-14T17:33:38.949Z] 17:33:38     INFO - Wait until the start button is displayed and enabled
[task 2020-07-14T17:33:38.950Z] 17:33:38     INFO - Buffered messages finished
[task 2020-07-14T17:33:38.950Z] 17:33:38     INFO - TEST-UNEXPECTED-FAIL | devtools/client/application/test/browser/browser_application_panel_telemetry-workers.js | Test timed out - 
[task 2020-07-14T17:33:39.167Z] 17:33:39     INFO - Removing tab.
[task 2020-07-14T17:33:39.168Z] 17:33:39     INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2020-07-14T17:33:39.183Z] 17:33:39     INFO - Got event: 'TabClose' on [object XULElement].
[task 2020-07-14T17:33:39.199Z] 17:33:39     INFO - Tab removed and finished closing
[task 2020-07-14T17:33:39.247Z] 17:33:39     INFO - TEST-PASS | devtools/client/application/test/browser/browser_application_panel_telemetry-workers.js | The main process DevToolsServer has no pending connection when the test ends - 
[task 2020-07-14T17:33:39.270Z] 17:33:39     INFO - GECKO(1274) | MEMORY STAT | vsize 3625MB | residentFast 624MB | heapAllocated 129MB
[task 2020-07-14T17:33:39.271Z] 17:33:39     INFO - TEST-OK | devtools/client/application/test/browser/browser_application_panel_telemetry-workers.js | took 45572ms
[task 2020-07-14T17:33:39.634Z] 17:33:39     INFO - checking window state
[task 2020-07-14T17:33:39.675Z] 17:33:39     INFO - TEST-START | devtools/client/application/test/browser/browser_application_panel_unregister-worker.js
[task 2020-07-14T17:33:39.771Z] 17:33:39     INFO - GECKO(1274) | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-07-14T17:33:40.052Z] 17:33:40     INFO - GECKO(1274) | Empty service worker registered
[task 2020-07-14T17:33:40.304Z] 17:33:40     INFO - GECKO(1274) | [CodeCoverage] Setting handlers for process 1902.
[task 2020-07-14T17:33:42.576Z] 17:33:42     INFO - GECKO(1274) | MEMORY STAT | vsize 3619MB | residentFast 635MB | heapAllocated 145MB
[task 2020-07-14T17:33:42.576Z] 17:33:42     INFO - TEST-OK | devtools/client/application/test/browser/browser_application_panel_unregister-worker.js | took 2909ms
[task 2020-07-14T17:33:42.934Z] 17:33:42     INFO - checking window state
[task 2020-07-14T17:33:42.956Z] 17:33:42     INFO - TEST-START | devtools/client/application/test/browser/browser_application_panel_worker-states.js
[task 2020-07-14T17:33:43.071Z] 17:33:43     INFO - GECKO(1274) | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-07-14T17:33:43.637Z] 17:33:43     INFO - GECKO(1274) | [CodeCoverage] Setting handlers for process 1929.
[task 2020-07-14T17:33:46.051Z] 17:33:46     INFO - GECKO(1274) | MEMORY STAT | vsize 3619MB | residentFast 644MB | heapAllocated 157MB
[task 2020-07-14T17:33:46.051Z] 17:33:46     INFO - TEST-OK | devtools/client/application/test/browser/browser_application_panel_worker-states.js | took 3090ms
[task 2020-07-14T17:33:46.409Z] 17:33:46     INFO - checking window state
[task 2020-07-14T17:33:47.138Z] 17:33:47     INFO - GECKO(1274) | [CodeCoverage] Setting handlers for process 1955.
[task 2020-07-14T17:33:50.384Z] 17:33:50     INFO - GECKO(1274) | Completed ShutdownLeaks collections in process 1955
[task 2020-07-14T17:33:50.581Z] 17:33:50     INFO - GECKO(1274) | Completed ShutdownLeaks collections in process 1382
[task 2020-07-14T17:33:50.604Z] 17:33:50     INFO - GECKO(1274) | Completed ShutdownLeaks collections in process 1363
[task 2020-07-14T17:33:50.632Z] 17:33:50     INFO - GECKO(1274) | Completed ShutdownLeaks collections in process 1929
[task 2020-07-14T17:33:54.514Z] 17:33:54     INFO - GECKO(1274) | Completed ShutdownLeaks collections in process 1274
[task 2020-07-14T17:33:54.515Z] 17:33:54     INFO - TEST-START | Shutdown
Summary: Perma [Tier 2] devtools/client/application/test/browser/browser_application_panel_telemetry-workers.js | Test timed out - → Perma devtools/client/application/test/browser/browser_application_panel_telemetry-workers.js | Test timed out -

Started failing on tier 1 as well, but it is intermittent

Summary: Perma devtools/client/application/test/browser/browser_application_panel_telemetry-workers.js | Test timed out - → High frequency devtools/client/application/test/browser/browser_application_panel_telemetry-workers.js | Test timed out -

Hi, I'm investigating this.

Flags: needinfo?(balbeza)

I'm unsure why this is permafailing in ccov. I'm trying with longer timeouts, but in the meantime maybe it's best to disable the test and keep this bug open while we find what's the root cause. (Try push here https://treeherder.mozilla.org/#/jobs?repo=try&revision=be4007c9a758b76a0c4346a1931c1c61af7cb418 )

Assignee: nobody → balbeza
Status: NEW → ASSIGNED
Keywords: leave-open
Backout by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c69a7f114fbf
Backed out changeset aa5b7db30aed as req by aa5b7db30aed. DONTBUILD CLOSED TREE
Attachment #9164367 - Attachment description: Bug 1652828 - Remove telemetry test from ccov platform → Bug 1652828 - Skip browser_application_panel_telemetry-workers.js test in ccov platform
Pushed by balbeza@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f8c223b7ff37
Skip browser_application_panel_telemetry-workers.js test in ccov platform r=jdescottes
Keywords: leave-open
Pushed by balbeza@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6fa683e60d96
Fix intermittent failure in app panel telemetry tests r=jdescottes
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 80
Regressions: 1654468
Regressions: 1654354
You need to log in before you can comment on or make changes to this bug.