Closed Bug 1643467 Opened 4 years ago Closed 1 year ago

Improve screen reader experience of 'Junk status' column in thread pane / message list

Categories

(Thunderbird :: Disability Access, defect, P3)

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: thomas8, Unassigned)

References

Details

(Keywords: access)

+++ This bug was initially created as a clone of Bug #1612055 +++
Originally reported by Jean-Philippe MENGUAL, bug 1612055, comment 0, against TB 74.
I have moved the accessibility aspect to this bug.

Steps to reproduce:

  • Upgrade TB Daily

Actual results:

  • All iconic colums are now bundled on the left side of thread pane / message list (bug 1612055), including "Junk Status" column (aka spam).
  • Orca screen reader says "unread 0 object etc" or "unread 100 object etc". 0 or 100 are the spam score (observed by Alex ARNAUD, bug 1612055, comment 1).
  • the spam score is a pain for a blind people, because the voice speaks it, but the average user has no idea what this number is about.

Expected results:

  • Improve the screen reader experience of spam column (this bug): It must communicate what it is about (current junk status of message), and what you can do there (change the junk status). Guess that needs aria-label attributes. Exact wording to be worked out.
  • Decide if spam score should be part of this column, and if yes, please communicate that to all users including those without screen readers (e.g. via tooltip). Otherwise, I think screen readers should just tell if the message is currently classified as Junk or not, which is the information currently available in the UI for users without screen readers.
  • Fix bug 1612055 (restore traditional default order of columns).
  • Fix bug 1622255 (preserve custom column order/layout).
Priority: P1 → P3

I think this has been solved as a part of bug 1813492

Yes. This has been fixed with the "Supernova" Thunderbird. It now announces "Spam".

(In reply to Peter Vágner from comment #1)

I think this has been solved as a part of bug 1813492

Thanks for pointing this out. I expect we won't be backporting these improvements to 102.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.