Closed Bug 1643522 Opened 1 month ago Closed 1 month ago

Select dropdowns no longer get zoomed based on full page zoom

Categories

(Toolkit :: General, defect)

defect

Tracking

()

VERIFIED FIXED
mozilla79
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 --- wontfix
firefox78 --- verified
firefox79 --- verified

People

(Reporter: Gijs, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR:

  1. open e.g. data:text/html,<select><option>A</option><option>A</option><option>A</option><option>A</option><option>A</option><option>A</option><option>A</option><option>A</option>

  2. ctrl+scroll to zoom

  3. open the dropdown

Regression range: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=03626342f6e659ac6699a21e30423e2267c1971f&tochange=ff7eec7be698cd21d92755d709e08897100fa9c8

I suspect the issue is that the code at https://searchfox.org/mozilla-central/rev/598e50d2c3cd81cd616654f16af811adceb08f9f/toolkit/actors/SelectParent.jsm#736-739 maybe doesn't look at the right thing anymore?

Flags: needinfo?(emilio)

(In reply to :Gijs (he/him) from comment #0)

I suspect the issue is that the code at https://searchfox.org/mozilla-central/rev/598e50d2c3cd81cd616654f16af811adceb08f9f/toolkit/actors/SelectParent.jsm#736-739 maybe doesn't look at the right thing anymore?

Or rather, the lines after it; https://hg.mozilla.org/integration/autoland/rev/a26615a65a8c201f2559bf2b0e952af5989162eb removed the browser's _fullZoom cache.

Assignee: nobody → emilio
Status: NEW → ASSIGNED
Flags: needinfo?(emilio)

Comment on attachment 9154497 [details]
Bug 1643522 - Use a sensible way to get the zoom for a browser in SelectParent.jsm. r=Gijs

Beta/Release Uplift Approval Request

  • User impact if declined: Zoom no longer affect selects.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: comment 0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simple patch to fix a regression introduced in 77.
  • String changes made/needed: none
Attachment #9154497 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8604456ea61e
Use a sensible way to get the zoom for a browser in SelectParent.jsm. r=Gijs
Flags: in-testsuite+
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/5d2eb51ff2c1
follow-up: Allow some floating point inaccuracies.
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79

Comment on attachment 9154497 [details]
Bug 1643522 - Use a sensible way to get the zoom for a browser in SelectParent.jsm. r=Gijs

regression fix, approved for 78.0b5

Attachment #9154497 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Reproduced the initial issue with Beta 78.0b4 (build id: 20200605150717) using Windows 10.
Verified - Fixed in latest Nightly build 79.0a1 (build id: 20200608213811) and Beta 78.0b5 (build id: 20200608141819) using Windows 10 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
Duplicate of this bug: 1644713
Regressions: 1647727
Regressions: 1650703
You need to log in before you can comment on or make changes to this bug.