Closed Bug 1643716 Opened 4 months ago Closed 3 months ago

Remove outdated rss feeds from SeaMonkey

Categories

(SeaMonkey :: Feed Discovery and Preview, task)

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53? affected, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.77
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 ? affected
seamonkey2.57esr ? affected

People

(Reporter: frg, Assigned: frg)

References

(Blocks 1 open bug)

Details

(Whiteboard: SM2.53.4)

Attachments

(2 files, 3 obsolete files)

We have a few no longer existing rss sites in suite/locales/en-US/chrome/browser/region.properties

Depends on: 1642450
Attached patch 1643716-1-rss-cleanup-2534.patch (obsolete) — Splinter Review

digg and aol are gone. Feedly seems to have changed the api. Only yahoo left. Others may be added at a later date if they support an api.

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: rss reader selections fails for some entries.
Testing completed (on m-c, etc.): 2.53.4
Risk to taking this patch (and alternatives if risky): trivial
String changes made by this patch: 1 scheme change 3 removals.

Attachment #9154586 - Flags: review?(iann_bugzilla)
Attachment #9154586 - Flags: approval-comm-release?
Attachment #9154586 - Flags: approval-comm-esr60?
Attached patch 1643716-2-rss-cleanup-2534.patch (obsolete) — Splinter Review

Drive by scheme https upgrades. Can go into another bug if desired.

Attachment #9154587 - Flags: review?(iann_bugzilla)
Attachment #9154587 - Flags: approval-comm-release?
Attachment #9154587 - Flags: approval-comm-esr60?
Comment on attachment 9154587 [details] [diff] [review]
1643716-2-rss-cleanup-2534.patch

[Triage Comment]
LGTM r/a=me
Attachment #9154587 - Flags: review?(iann_bugzilla)
Attachment #9154587 - Flags: review+
Attachment #9154587 - Flags: approval-comm-release?
Attachment #9154587 - Flags: approval-comm-release+
Attachment #9154587 - Flags: approval-comm-esr60?
Attachment #9154587 - Flags: approval-comm-esr60+

(In reply to Frank-Rainer Grahl (:frg) from comment #1)

Created attachment 9154586 [details] [diff] [review]
1643716-1-rss-cleanup-2534.patch

digg and aol are gone. Feedly seems to have changed the api. Only yahoo left. Others may be added at a later date if they support an api.

Potential replacement Feedly API is:
https://feedly.com/i/discover/sources/search/leo/%s

Other potential online feed readers:
https://www.inoreader.com?add_feed=%s
https://www.newsblur.com/?url=%s

Did look at feeder.co but not sure there is an API for adding a feed

Also from other locales:
From cs (both seem to be alive):
https://theoldreader.com/feeds/subscribe?url=%s
https://www.g2reader.com/su?u=%s

From fr (seems alive):
https://www.netvibes.com/subscribe.php?url=%s

From ja (feedly one seems better than previous comment, but feedwatcher seems ja only and perhaps broken):
https://feedly.com/i/subscription/feed/%s
https://feedwatcher.net/main/Addfeed?url=%s

Other locales either have some of the above, same as en-US or additional broken ones e.g. Google and Bloglines

Comment on attachment 9154586 [details] [diff] [review]
1643716-1-rss-cleanup-2534.patch

f+ for the moment as we have an updated uri for Feedly and I think there are some additional options that could be added inoreader and maybe netvibes.
Attachment #9154586 - Flags: review?(iann_bugzilla)
Attachment #9154586 - Flags: feedback+
Attachment #9154586 - Flags: approval-comm-release?
Attachment #9154586 - Flags: approval-comm-esr60?
Attached patch 1643716-3-rss-cleanup-2534.patch (obsolete) — Splinter Review

Add back Feedly with a different url and add Inoreader as a start. If requested we can add others later.

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: no choices
Testing completed (on m-c, etc.): 2.53.4
Risk to taking this patch (and alternatives if risky): trivial
String changes made by this patch: Adding browser.contentHandlers.types.*

The selection code code seems to have an old bug. If you select a web reader it will always be choosen unless you reset browser.feeds.handler.default, Fixing this is for another bug.

Attachment #9157822 - Flags: review?(iann_bugzilla)
Attachment #9157822 - Flags: approval-comm-release?
Attachment #9157822 - Flags: approval-comm-esr60?

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: non working rss reader sites can be selected.
Testing completed (on m-c, etc.): 2.53.4
Risk to taking this patch (and alternatives if risky): broken already.
String changes made by this patch: rowser.contentHandlers.types.*

Attachment #9154586 - Attachment is obsolete: true
Attachment #9157822 - Attachment is obsolete: true
Attachment #9157822 - Flags: review?(iann_bugzilla)
Attachment #9157822 - Flags: approval-comm-release?
Attachment #9157822 - Flags: approval-comm-esr60?
Attachment #9157963 - Flags: review?(iann_bugzilla)
Attachment #9157963 - Flags: approval-comm-release?
Attachment #9157963 - Flags: approval-comm-esr60?

Part 2 rebased after changing part 1. r/a+ from IanN retained.

Attachment #9157964 - Flags: review+
Attachment #9157964 - Flags: approval-comm-release+
Attachment #9157964 - Flags: approval-comm-esr60+
Attachment #9154587 - Attachment is obsolete: true
Comment on attachment 9157963 [details] [diff] [review]
1643716-1-rss-cleanup-2534.patch

[Triage Comment]
LGTM r/a=me
Attachment #9157963 - Flags: review?(iann_bugzilla)
Attachment #9157963 - Flags: review+
Attachment #9157963 - Flags: approval-comm-release?
Attachment #9157963 - Flags: approval-comm-release+
Attachment #9157963 - Flags: approval-comm-esr60?
Attachment #9157963 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/a18f6dd87362
Part 1: Replace no longer working rss services in SeaMonkey. r=IanN
https://hg.mozilla.org/comm-central/rev/57ace8b7daf7
Part 2: Upgrade regional http links to https. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.77
Whiteboard: SM2.53.4
You need to log in before you can comment on or make changes to this bug.