SetDirty() often uses uninitialized rv

RESOLVED FIXED

Status

()

Core
History: Global
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: Andrew Schultz, Assigned: Blake Ross)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
found this with valgrind
if mSynctimer is non-null (after the first time SetDirty is called), then
do_CreateInstance is not called, but rv is still checked and SetDirty returns
failure if NS_FAILED(rv) is true.

this code came from bug 65862.
(Reporter)

Comment 1

16 years ago
Created attachment 96535 [details] [diff] [review]
only check rv if do_CreateInstance is called
(Reporter)

Updated

16 years ago
Keywords: patch, review

Comment 2

16 years ago
Comment on attachment 96535 [details] [diff] [review]
only check rv if do_CreateInstance is called

r=dbradley
Attachment #96535 - Flags: review+

Comment 3

16 years ago
Comment on attachment 96535 [details] [diff] [review]
only check rv if do_CreateInstance is called

thanks!
sr=alecf
Attachment #96535 - Flags: superreview+
(Reporter)

Comment 4

16 years ago
*** Bug 165030 has been marked as a duplicate of this bug. ***
Blocks: 179819
(Reporter)

Comment 5

15 years ago
blaker, dbradley or alecf: could one of you check this patch in to CVS?  thanks
Keywords: review

Comment 6

15 years ago
Patch checked in

Comment 7

15 years ago
SetDirty() often uses uninitialized rv
Patch was checked in 40 days ago: 2002-11-13
Why is that bug status still marked NEW, not resolved?
It is one of twenty bugs blocking bug 179819

Comment 8

15 years ago
Because I forgot?
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.