Closed Bug 164464 Opened 18 years ago Closed 18 years ago

Importxml will fail if versioncache needs update

Categories

(Bugzilla :: Bug Import/Export & Moving, defect)

2.16
x86
Other
defect
Not set
major

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: bugreport, Assigned: myk)

References

Details

(Whiteboard: [fixed in 2.16.1])

Attachments

(1 file)

importxml tries to get the version table before connecting to the database. 
This will fail if GetVersionTable needs to regenerate the version table.

GetVersionTable();
ConnectToDatabase();
                           
This is true in all the major branches.
Comment on attachment 96588 [details] [diff] [review]
Fix - needed on 2.16 as well as 2.17

r=burnus
Attachment #96588 - Flags: review+
Attachment #96588 - Flags: review+
Comment on attachment 96588 [details] [diff] [review]
Fix - needed on 2.16 as well as 2.17

r=bbaetz x2

The versiontable sucks
Attachment #96588 - Flags: review+
Attachment #96588 - Flags: review+
Checked in

On HEAD:
Checking in importxml.pl;                                    
/cvsroot/mozilla/webtools/bugzilla/importxml.pl,v  <--  importxml.pl
new revision: 1.27; previous revision: 1.26
done                

And on BUGZILLA-2_16-BRANCH
/cvsroot/mozilla/webtools/bugzilla/importxml.pl,v  <--  importxml.pl
new revision: 1.23.2.1; previous revision: 1.23
done                 
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Whiteboard: [fixed in 2.16.1]
Target Milestone: --- → Bugzilla 2.18
*** Bug 147599 has been marked as a duplicate of this bug. ***
Component: Creating/Changing Bugs → Bug Import/Export & Moving
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.