Closed Bug 1645271 Opened 3 months ago Closed 3 months ago

Links in Account Manager open in browser window but also replace the Tab content

Categories

(Thunderbird :: General, defect, P1)

Tracking

(thunderbird78+ fixed)

RESOLVED FIXED
Thunderbird 79.0
Tracking Status
thunderbird78 + fixed

People

(Reporter: aleca, Assigned: aleca)

Details

(Keywords: regression, regressionwindow-wanted)

Attachments

(1 file)

Click one of the many links in the Resources section at the bottom of the new Account Manager.
The link opens correctly in the default browser, but also gets loaded in the tab itself, replacing the entire content.

This is a regression as it never happened before, and surely it didn't used to happen when first implementing the Account Manager.

I'm setting P1 and S1 as it's pretty disruptive since it prevents the usage of the entire tab.

Adding a simple preventDefault prevents the link from opening the URL inline the content.

I'm not sure if that's the right way to fix this issue, and if this is the tip of a deeper problem we might encounter with links and the way we manage it.

Assignee: nobody → alessandro
Status: NEW → ASSIGNED
Attachment #9156140 - Flags: review?(geoff)
Comment on attachment 9156140 [details] [diff] [review]
1645271-accountCentral-links.diff

Yeah, that should do it. I'm not sure why this would've changed either but it seems alright in 77.
Attachment #9156140 - Flags: review?(geoff) → review+
Target Milestone: --- → Thunderbird 79.0

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/4979e018d129
Prevent the opening of links in the Account Central content Tab. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Comment on attachment 9156140 [details] [diff] [review]
1645271-accountCentral-links.diff

Fix for unknown regression in 78.
Attachment #9156140 - Flags: approval-comm-beta?
Comment on attachment 9156140 [details] [diff] [review]
1645271-accountCentral-links.diff

Approved for beta
Attachment #9156140 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.