Closed Bug 1646158 Opened 3 months ago Closed 3 months ago

Various clang-plugin updates for clang 11

Categories

(Firefox Build System :: Source Code Analysis, defect)

defect

Tracking

(firefox79 fixed)

RESOLVED FIXED
mozilla79
Tracking Status
firefox79 --- fixed

People

(Reporter: dmajor, Assigned: dmajor)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

No description provided.

In https://github.com/llvm/llvm-project/commit/8a81daaa8b58aeaa192a47c4ce7f94b4d59ce082, the class DynTypedNodeList moved from ASTContext to global level.

Sometime during clang 11 (I don't have the exact commit handy), the display of nested templates changed from Foo<Bar<X> > to Foo<Bar<X>>.

In https://github.com/llvm/llvm-project/commit/adcd02683856c30ba6f349279509acecd90063df, conversions from StringRef to std::string became explicit.

The NFC fix would be to wrap the conversions in std::string(...) but since these are all short-lived uses for things like string compares, I've refactored a bit to keep them in native form.

Pushed by dmajor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/70b1b14bf281
Make nested template checks work with clang 11 r=static-analysis-reviewers,andi
https://hg.mozilla.org/integration/autoland/rev/6733a8ca5908
Make `DynTypedNodeList` work with clang11 r=static-analysis-reviewers,andi
https://hg.mozilla.org/integration/autoland/rev/50a3843bd942
Fix StringRef conversions in clang-plugin for clang 11 r=static-analysis-reviewers,andi
Duplicate of this bug: 1625003
Duplicate of this bug: 1625004
You need to log in before you can comment on or make changes to this bug.