Closed Bug 1646810 Opened 5 months ago Closed 1 month ago

GeckoView needs to start using DocumentChannel process switching (instead of E10SUtils)

Categories

(GeckoView :: General, task, P1)

Tracking

(Fission Milestone:Future, firefox84 fixed)

RESOLVED FIXED
84 Branch
Fission Milestone Future
Tracking Status
firefox84 --- fixed

People

(Reporter: neha, Assigned: agi)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

(Whiteboard: [geckoview:m84])

Attachments

(6 files, 1 obsolete file)

In order to prep for Fission on Android, GeckoView needs to start using DocumentChannel process switching. This was discussed during the Fission on Android meeting today.
NI'ing snorp to find the right assignee for this.

Flags: needinfo?(snorp)
Flags: needinfo?(snorp)
Product: Firefox for Android → GeckoView
Summary: GeckoView needs to start using DocumentChannel process switching → GeckoView needs to start using DocumentChannel process switching (instead of E10SUtils)
Blocks: fission

Tracking for Fission Future because Android Fission doesn't block shipping Fission MVP on desktop.

Fission Milestone: --- → Future

Agi, I was going to file a new bug (per https://phabricator.services.mozilla.com/D92514#2983616 ) but bugzilla flagged this up as a possible dupe; does that work?

Flags: needinfo?(agi)
See Also: → 1640019

Ah yes, that's perfect, thanks!

Flags: needinfo?(agi)
Whiteboard: [geckoview:m84]
Priority: P2 → P1
Assignee: nobody → agi

This is a temporary workaround so that we can test Fission on GeckoView without
implementiong SessionStateAggregator, which needs to be moved to the parent
since Fission implies HistoryInParent.

Blocks: 1671983
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/017ecd33c3b8
Add processes tab4-tab49. r=snorp
https://hg.mozilla.org/integration/autoland/rev/bac3d07c198b
Expose browser-custom-element::afterChangeRemoteness. r=nika
https://hg.mozilla.org/integration/autoland/rev/8c47d83bfe4d
HistoryInParent workaround for SessionStateAggregator. r=esawin
https://hg.mozilla.org/integration/autoland/rev/f087af9e75e6
Use DocumentChannel process switching. r=nika,owlish

Comment on attachment 9182723 [details]
Bug 1646810 - Pass correct flags in ProgessTracker's listener.

Revision D94171 was moved to bug 1672247. Setting attachment 9182723 [details] to obsolete.

Attachment #9182723 - Attachment is obsolete: true
Keywords: leave-open
Attachment #9182746 - Attachment description: Bug 1646810 - Remove unused restoreProgressListeners → Bug 1646810 - Remove unused restoreProgressListeners.
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a2ed93bf78d5
Remove unused restoreProgressListeners. r=kmag
Keywords: leave-open
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/51a5a97203d1
Unlock fission.autostart on Android. r=snorp
Regressions: 1673891
You need to log in before you can comment on or make changes to this bug.