Closed Bug 1647227 Opened 4 years ago Closed 1 year ago

"Run Junk Mail Controls" does not give feedback - window.MsgStatusFeedback is undefined

Categories

(Thunderbird :: Filters, defect)

Thunderbird 113
defect

Tracking

(thunderbird_esr102 wontfix)

RESOLVED FIXED
114 Branch
Tracking Status
thunderbird_esr102 --- wontfix

People

(Reporter: mozbug444, Assigned: mkmelin)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:77.0) Gecko/20100101 Firefox/77.0

Steps to reproduce:

Opened a message in the Junk folder, right-clicked and selected Mark / Run Junk Mail Controls.

I do have "Enable adaptive junk filter logging" enabled, although I would expect to see some UI regardless of the setting of this.

I'm running TB 78.0b2 64-bit on Ubuntu 20.04 GNOME.

Actual results:

Nothing happened, no dialog or UI or anything.

Expected results:

Expect to see some dialog to do Junk mail controls.

Component: Untriaged → Filters
Type: defect → enhancement
Summary: "Run Junk Mail Controls" does nothing → "Run Junk Mail Controls" does not give feedback

Why was this changed to "enhancement" ? As far as I can tell, the feature does not work at all. It's a defect.

Please change this back to "defect".

Severity: -- → S4
Type: enhancement → defect
Keywords: dupeme

It does provide (quick) feedback in the status bar. For activity manager there is bug 1544471.
It may happen too quickly to notice though.

I'm grabbing this bug to fix that, since on trunk/beta we have a bug so it doesn't work at all.

Uncaught TypeError: window.MsgStatusFeedback is undefined
onMessageClassified chrome://messenger/content/junkCommands.js:245
junkCommands.js:245:7

Keywords: dupemeregression
Summary: "Run Junk Mail Controls" does not give feedback → "Run Junk Mail Controls" does not give feedback - window.MsgStatusFeedback is undefined
Whiteboard: [Supernova]
Version: 78 → Thunderbird 113

Fix the issue on trunk (window vs top.window), clean up documentation, and add a 500ms delay before removing the status message from the status bar.

Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Whiteboard: [Supernova] → [Supernova3p]
Attachment #9329417 - Attachment description: Bug 1647227 - "Run Junk Mail Controls" does not give feedback - window.MsgStatusFeedback is undefined. r=#thunderbird-reviewers → Bug 1647227 - "Run Junk Mail Controls" does not give feedback - window.MsgStatusFeedback is undefined. r=aleca
Target Milestone: --- → 114 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/1b864dfb7131
"Run Junk Mail Controls" does not give feedback - window.MsgStatusFeedback is undefined. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: