Closed Bug 1648328 Opened 7 months ago Closed 7 months ago

Hit MOZ_CRASH(assertion failed: combined_local_clip_rect.size.width >= 0.0 && combined_local_clip_rect.size.height >= 0.0) at gfx/wr/webrender/src/prim_store/mod.rs:2148

Categories

(Core :: Graphics: WebRender, defect)

defect

Tracking

()

RESOLVED FIXED
mozilla79
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox77 --- unaffected
firefox78 --- unaffected
firefox79 --- fixed

People

(Reporter: tsmith, Assigned: gw)

References

(Blocks 2 open bugs)

Details

(Keywords: assertion, testcase, Whiteboard: [bugmon:confirmed])

Attachments

(3 files)

Attached file testcase.html

Hit MOZ_CRASH(assertion failed: combined_local_clip_rect.size.width >= 0.0 && combined_local_clip_rect.size.height >= 0.0) at gfx/wr/webrender/src/prim_store/mod.rs:2148

56|0|libxul.so|RustMozCrash|hg:hg.mozilla.org/mozilla-central:mozglue/static/rust/wrappers.cpp:279fd282a0aed1ee2c259ce7e6216e048bb3b7f9|17|0x15
56|1|libxul.so|mozglue_static::panic_hook|hg:hg.mozilla.org/mozilla-central:mozglue/static/rust/lib.rs:279fd282a0aed1ee2c259ce7e6216e048bb3b7f9|89|0x9
56|2|libxul.so|core::ops::function::Fn::call|git:github.com/rust-lang/rust:src/libcore/ops/function.rs:4fb7144ed159f94491249e86d5bbd033b5d60550|72|0xc
56|3|libxul.so|std::panicking::rust_panic_with_hook|git:github.com/rust-lang/rust:src/libstd/panicking.rs:4fb7144ed159f94491249e86d5bbd033b5d60550|474|0x7
56|4|libxul.so|std::panicking::begin_panic|git:github.com/rust-lang/rust:src/libstd/panicking.rs:4fb7144ed159f94491249e86d5bbd033b5d60550|397|0x27
56|5|libxul.so|webrender::prim_store::PrimitiveStore::update_visibility|hg:hg.mozilla.org/mozilla-central:gfx/wr/webrender/src/prim_store/mod.rs:279fd282a0aed1ee2c259ce7e6216e048bb3b7f9|2148|0x18
56|6|libxul.so|webrender::prim_store::PrimitiveStore::update_visibility|hg:hg.mozilla.org/mozilla-central:gfx/wr/webrender/src/prim_store/mod.rs:279fd282a0aed1ee2c259ce7e6216e048bb3b7f9|1945|0x2b
56|7|libxul.so|webrender::frame_builder::FrameBuilder::build|hg:hg.mozilla.org/mozilla-central:gfx/wr/webrender/src/frame_builder.rs:279fd282a0aed1ee2c259ce7e6216e048bb3b7f9|385|0x2a
56|8|libxul.so|webrender::render_backend::Document::build_frame|hg:hg.mozilla.org/mozilla-central:gfx/wr/webrender/src/render_backend.rs:279fd282a0aed1ee2c259ce7e6216e048bb3b7f9|615|0x22
56|9|libxul.so|webrender::render_backend::RenderBackend::update_document|hg:hg.mozilla.org/mozilla-central:gfx/wr/webrender/src/render_backend.rs:279fd282a0aed1ee2c259ce7e6216e048bb3b7f9|1520|0x1a
56|10|libxul.so|webrender::render_backend::RenderBackend::process_api_msg|hg:hg.mozilla.org/mozilla-central:gfx/wr/webrender/src/render_backend.rs:279fd282a0aed1ee2c259ce7e6216e048bb3b7f9|1357|0x23
56|11|firefox-bin|replace_free(void*)|hg:hg.mozilla.org/mozilla-central:memory/replace/phc/PHC.cpp:279fd282a0aed1ee2c259ce7e6216e048bb3b7f9|1312|0x27
56|12|libxul.so|webrender::resource_cache::ResourceCache::post_scene_building_update|hg:hg.mozilla.org/mozilla-central:gfx/wr/webrender/src/resource_cache.rs:279fd282a0aed1ee2c259ce7e6216e048bb3b7f9|619|0x41
56|13|libxul.so|mozilla::layers::WebRenderBridgeParent::DeleteImage(mozilla::wr::ImageKey const&, mozilla::wr::TransactionBuilder&)|hg:hg.mozilla.org/mozilla-central:gfx/layers/wr/WebRenderBridgeParent.cpp:279fd282a0aed1ee2c259ce7e6216e048bb3b7f9|1673|0xb
56|14|libxul.so|mozilla::layers::OpUpdateResource::AssertSanity(mozilla::layers::OpUpdateResource::Type) const|s3:gecko-generated-sources:14767795184cd2486e8046aa7e84606a44ba5b021ed3fb28684afbd09ab664ab6d0245f6c4b5d843024f6014734e21bf551b16e15ce6fab941a75b6cfd48cae8/ipc/ipdl/_ipdlheaders/mozilla/layers/WebRenderMessages.h:|3117|0x5
56|15|firefox-bin|PageFree(mozilla::Maybe<unsigned long> const&, void*)|hg:hg.mozilla.org/mozilla-central:memory/replace/phc/PHC.cpp:279fd282a0aed1ee2c259ce7e6216e048bb3b7f9|1276|0x9
56|16|libxul.so|webrender::scene::SceneProperties::flush_pending_updates|hg:hg.mozilla.org/mozilla-central:gfx/wr/webrender_api/src/api.rs:279fd282a0aed1ee2c259ce7e6216e048bb3b7f9|1977|0x5
56|17|libxul.so|mozilla::layers::OpUpdateResource::AssertSanity(mozilla::layers::OpUpdateResource::Type) const|s3:gecko-generated-sources:14767795184cd2486e8046aa7e84606a44ba5b021ed3fb28684afbd09ab664ab6d0245f6c4b5d843024f6014734e21bf551b16e15ce6fab941a75b6cfd48cae8/ipc/ipdl/_ipdlheaders/mozilla/layers/WebRenderMessages.h:|3117|0x5
56|18|linux-gate.so||||0xc30
56|19|libxul.so|webrender::render_backend::RenderBackend::update_document|hg:hg.mozilla.org/mozilla-central:gfx/wr/webrender/src/render_backend.rs:279fd282a0aed1ee2c259ce7e6216e048bb3b7f9|1626|0xd
Flags: in-testsuite?
Attached file prefs.js
Keywords: bugmon

A Pernosco session is available here: https://pernos.co/debug/Qo_B0AhEaaDpMzgZvsAHxg/index.html

Keywords: bugmon
Whiteboard: [bugmon:confirmed]
Bugmon Analysis:
Unable to reproduce bug using the following builds:
> mozilla-central 20200625161839-324d5257f6f7
> mozilla-central 20200625032232-52994209c733
Removing bugmon keyword as no further action possible.
Please review the bug and re-add the keyword for further analysis.
Severity: -- → S3

The code already explicitly checks for and handles the rect here
having a zero or invalid size, there is no need to assert that
the rect size itself is valid.

Assignee: nobody → gwatson
Status: NEW → ASSIGNED
Pushed by gwatson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0dfbacabae09
Remove a redundant assertion check. r=Bert
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
You need to log in before you can comment on or make changes to this bug.