Closed Bug 1648585 Opened 2 years ago Closed 2 years ago

Chat participant flags missing

Categories

(Thunderbird :: Instant Messaging, defect)

defect

Tracking

(thunderbird_esr78 fixed, thunderbird79 fixed)

RESOLVED FIXED
Thunderbird 80.0
Tracking Status
thunderbird_esr78 --- fixed
thunderbird79 --- fixed

People

(Reporter: clokep, Assigned: khushil324)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

The participants list does not seem to be showing operator flags anymore on TB 78b2.

In the attachment I'm an operator so I should have a gold star before my name.

My hunch is that this was either due to:

  • de-XBL
  • The modifications for OTR

khushil / aleca -- any idea of when this might have been affected?

Assignee: nobody → khushil324
Regressed by: 1627927
Status: NEW → ASSIGNED
Comment on attachment 9163462 [details] [diff] [review]
Bug-1648585_Chat-participant-flags-missing-0.patch

Review of attachment 9163462 [details] [diff] [review]:
-----------------------------------------------------------------

Seems to just revert the change from bug 1627927. Thanks for tracking this down!
Attachment #9163462 - Flags: review?(clokep) → review+

Comment on attachment 9163462 [details] [diff] [review]
Bug-1648585_Chat-participant-flags-missing-0.patch

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined:
Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: This was regressed in Thunderbird 77, the patch reverts code from bug 1627927.
  • User impact if declined: Users are unable to tell whether a user in a chat room is an "admin" or "moderator", this could have privacy implications.
  • Fix Landed on Version: 80
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Worst case this still won't work.
  • String or UUID changes made by this patch:
Attachment #9163462 - Flags: approval-mozilla-esr78?
Attachment #9163462 - Flags: approval-comm-beta?
Attachment #9163462 - Flags: approval-mozilla-esr78? → approval-comm-esr78?

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/816233818fd0
Fix missing chat participant flags. r=clokep DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 80.0
Comment on attachment 9163462 [details] [diff] [review]
Bug-1648585_Chat-participant-flags-missing-0.patch

Approved for beta
Attachment #9163462 - Flags: approval-comm-beta? → approval-comm-beta+
Comment on attachment 9163462 [details] [diff] [review]
Bug-1648585_Chat-participant-flags-missing-0.patch

Approved for esr78
Attachment #9163462 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.