Closed Bug 1648668 Opened 11 months ago Closed 11 months ago

"mach bootstrap" fails with "Could not find artifacts for a toolchain build named `linux64-minidump-stackwalk`"

Categories

(Firefox Build System :: Bootstrap Configuration, defect)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1636797

People

(Reporter: heycam, Unassigned)

References

(Blocks 1 open bug)

Details

 0:01.95 Could not find artifacts for a toolchain build named `linux64-minidump-stackwalk`. Local commits, dirty/stale files, and other changes in your checkout may cause this error. Make sure you are on a fresh, current checkout of mozilla-central. If you are already, you may be able to avoid this error by running `mach clobber python`. Beware that commands like `mach bootstrap` and `mach artifact` are unlikely to work on any versions of the code besides recent revisions of mozilla-central.
Error running mach:

    ['bootstrap']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file bootstrap| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

subprocess.CalledProcessError: Command '['/usr/bin/python3', '/z/moz/l/mach', 'artifact', 'toolchain', '--bootstrap', '--from-build', 'linux64-minidump-stackwalk']' returned non-zero exit status 1.

  File "/z/moz/l/python/mozboot/mozboot/mach_commands.py", line 46, in bootstrap
    bootstrapper.bootstrap()
  File "/z/moz/l/python/mozboot/mozboot/bootstrap.py", line 565, in bootstrap
    checkout_root)
  File "/z/moz/l/python/mozboot/mozboot/bootstrap.py", line 414, in maybe_install_private_packages_or_exit
    self.instance.ensure_minidump_stackwalk_packages(state_dir, checkout_root)
  File "/z/moz/l/python/mozboot/mozboot/linux_common.py", line 128, in ensure_minidump_stackwalk_packages
    minidump_stackwalk.LINUX_MINIDUMP_STACKWALK)
  File "/z/moz/l/python/mozboot/mozboot/base.py", line 353, in install_toolchain_artifact
    subprocess.check_call(cmd, cwd=state_dir)
  File "/usr/lib/python3.7/subprocess.py", line 363, in check_call
    raise CalledProcessError(retcode, cmd)
Sentry is attempting to send 0 pending error messages
Waiting up to 2 seconds
Press Ctrl-C to quit

Looks like a dup of bug 1637042, mach clobber python will likely fix your issue.

I tried ./mach clobber python (per the error message's instructions) but it didn't help.

I believe that's exactly like bug 1636797. Please reopen if I'm wrong.

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1636797
You need to log in before you can comment on or make changes to this bug.