Closed Bug 1648680 Opened 7 months ago Closed 6 months ago

Implicit declaration of WSAIoctl in w95sock.c

Categories

(NSPR :: NSPR, defect)

defect

Tracking

(firefox80 fixed)

RESOLVED FIXED
Tracking Status
firefox80 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(2 files)

No description provided.

The severity field is not set for this bug.
:KaiE, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(kaie)
Severity: -- → S3
Flags: needinfo?(kaie)
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/128b0d6ba0b5
Do not build w95sock.c as part of a unified compilation unit. r=dmajor
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED

IIUC you worked around the header issue by using a change to the firefox build system.

Do you want the change to NSPR to uplift for FF 80, or can it wait longer?

Flags: needinfo?(mh+mozilla)

The issue is not worked around in Firefox. The Firefox change is to preemptively fix the fact that the NSPR change breaks unified builds because both winsock2.h and winsock.h would be included, which breaks.

It would be good to have asap in Firefox to be able to land bug 822978.

Flags: needinfo?(mh+mozilla)
Blocks: 1652330
Target Milestone: --- → 4.27
You need to log in before you can comment on or make changes to this bug.