Closed Bug 1652330 Opened 1 year ago Closed 1 year ago

Firefox 80 should pick up NSPR 4.27

Categories

(Firefox Build System :: General, enhancement)

enhancement

Tracking

(firefox80 fixed)

RESOLVED FIXED
mozilla80
Tracking Status
firefox80 --- fixed

People

(Reporter: KaiE, Assigned: KaiE)

References

Details

Attachments

(4 files)

Firefox 80 should pick up NSPR 4.27

Keywords: leave-open

UPGRADE_NSPR_RELEASE

See Also: → 1652331
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/d4946a4c5aa9
NSPR 4.27 snapshot 1. r=glandium
Depends on: 1648836
No longer depends on: 1648836
Depends on: 1652956
Blocks: 1648836

We'll also need the PR_Access fix uplifted to ESR 68, to address bug 1649764.

(In reply to Markus Stange [:mstange] from comment #5)

We'll also need the PR_Access fix uplifted to ESR 68, to address bug 1649764.

ESR 68 ? Or ESR 78 ? Or both?

Those branches use older NSPR releases. To uplift, I'll have to create matching NSPR branch releases.

It seems :glandium is worried that the fix from bug 1652956 might regress an original fix from bug 480730.
But I have trouble to understand which regression that would be.

I'd like to wait for glandium's response, prior to creating the NSPR branch releases.

Flags: needinfo?(mstange.moz)

(In reply to Kai Engert (:KaiE:) from comment #6)

(In reply to Markus Stange [:mstange] from comment #5)

We'll also need the PR_Access fix uplifted to ESR 68, to address bug 1649764.

ESR 68 ? Or ESR 78 ? Or both?

Probably both; definitely 78. (I'm not sure how long we support 68.)
Bug 1649764 was filed about 68 and also mentions the Tor browser.
The current status is that 68 cannot render web content on macOS Big Sur because 68 requires OpenGL for that.
78 can render web content on macOS Big Sur (because of a different fix that allows using BasicCompositor without OpenGL), but it does not have hardware acceleration or WebGL on macOS Big Sur.

(In reply to Kai Engert (:KaiE:) from comment #6)

I'd like to wait for glandium's response, prior to creating the NSPR branch releases.

That sounds good to me.

Flags: needinfo?(mstange.moz)
Attachment #9163982 - Attachment description: Bug 1652330 - NSPR 4.27 dev snapshot 2 to pick up a fix for macOS 11. r=kjacobs → Bug 1652330 - NSPR 4.27 dev snapshot 2 to pick up a fix for macOS 11. r=kjacobs UPGRADE_NSPR_RELEASE
Pushed by kaie@kuix.de:
https://hg.mozilla.org/integration/autoland/rev/1b9d508de575
NSPR 4.27 dev snapshot 2 to pick up a fix for macOS 11. r=kjacobs UPGRADE_NSPR_RELEASE

So there was indeed a regression found, in NSS. In the meantime we understand what's happening.
I'm not yet sure what we should do on old branches.
Let's wait for the discussion that i started in bug 1648836 comment 13.

To clarify:
Creating .x updates of the old NSPR releases is possible.
However, everyone using macOS with those old NSPR versions and also using NSS would potentially run into a regression (incorrect library of root CA certificates being loaded).
We'd have to require that all NSPR users on macOS also upgrade to a fixed NSS.
It would require that in addition to old NSPR .x updates, corresponding NSS .x updates would have to be released, too.

If bug 1648836 gives us a simple answer to my question, then we could avoid the change of behavior in old NSPR, by limiting the change to known macOS system libraries.

Attachment #9165106 - Attachment description: Bug 1652330 - NSPR_4_27_BETA1 to pick up a backwards compatible macOS 11 system library fix. r=kjacobs → Bug 1652330 - NSPR_4_27_BETA1 to pick up a backwards compatible macOS 11 system library fix. r=kjacobs UPGRADE_NSPR_RELEASE
Pushed by kaie@kuix.de:
https://hg.mozilla.org/integration/autoland/rev/ab5df936a207
NSPR_4_27_BETA1 to pick up a backwards compatible macOS 11 system library fix. r=kjacobs UPGRADE_NSPR_RELEASE
Keywords: leave-open
Attachment #9165676 - Attachment description: Bug 1652330 - NSPR_4_27_RTM. r=jcj → Bug 1652330 - NSPR_4_27_RTM. r=jcj UPGRADE_NSPR_RELEASE
Pushed by jjones@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ceba0316cf3c
NSPR_4_27_RTM. r=jcj UPGRADE_NSPR_RELEASE
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
Regressions: 1655367
You need to log in before you can comment on or make changes to this bug.