Closed Bug 1648854 Opened 2 months ago Closed 1 month ago

Telemetry Logging has stopped working

Categories

(Toolkit :: Telemetry, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox77 --- unaffected
firefox78 --- unaffected
firefox79 --- fixed
firefox80 --- fixed

People

(Reporter: chutten, Assigned: kmag)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Telemetry Logging can be turned on by setting toolkit.telemetry.log.level to a log level (e.g. Trace). You can get it to pipe to console by setting toolkit.telemetry.log.dump to the boolean true.

This isn't working with latest mozilla-central, but reverting the two patches from bug 1645862 (and the one from bug 1648178 first so it doesn't complain about merge conflicts) makes it work again.

My only guess is the logger is configured someplace in TelemetryController and I missed that it was no longer called in the review.

Setting the log level on a logger with a prefix doesn't work, because the
property isn't a setter, and prefix loggers use Object.create to create a new
object with the real logger as their prototype.

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80

The patch landed in nightly and beta is affected.
:kmag, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(kmaglione+bmo)

(In reply to Release mgmt bot [:sylvestre / :calixte / :marco for bugbug] from comment #5)

The patch landed in nightly and beta is affected.

I don't know. I think that's for someone who works on Telemetry to decide. Normal users won't notice that at all. It only matters for debugging.

Flags: needinfo?(kmaglione+bmo) → needinfo?(chutten)

I think we should uplift as any run-on-beta testsfails would miss crucial information.

Flags: needinfo?(chutten)

Comment on attachment 9159857 [details]
Bug 1648854: Fix telemetry logging. r=dexter

Beta/Release Uplift Approval Request

  • User impact if declined: None to end users. Devs might have a harder time dealing with test failures with a lack of logs.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The risk is low because this is a change to logging in the Telemetry component which is off by default (on by default in tests)
  • String changes made/needed:
Attachment #9159857 - Flags: approval-mozilla-beta?

Comment on attachment 9159857 [details]
Bug 1648854: Fix telemetry logging. r=dexter

Approved for 79.0b6.

Attachment #9159857 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.