Closed Bug 1649537 Opened 4 years ago Closed 4 years ago

History buttons don't work in Responsive Design Mode

Categories

(DevTools :: Responsive Design Mode, defect, P2)

78 Branch
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1644248

People

(Reporter: luca, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

Switch in responsive view mode (Ctrl+Shift+M), try to navigate on previous pages with the back button.

Actual results:

History buttons (previous and next page in browsing history) don't work, if you click them nothing happens.
If you click and hold the list of visited pages appears, and if you click on one of them, it works.
I already tried on a clean profile, the problem remains.

Expected results:

The buttons shoud work.

The same bug was on version 77

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Responsive Design Mode
Product: Firefox → DevTools

Thank you for reporting this. I can confirm this issue is still happening on Firefox 78.

We fixed a similar issue in Bug 1644248, which should now be available in Firefox Developer Edition - version 79 and Firefox Nightly - version 80. I've tried to reproduce the issue on those versions and it looks like the issue has been fixed there. Can you confirm if this issue has also been fixed for you on those versions?

Severity: -- → S2
Flags: needinfo?(luca)
Priority: -- → P2
See Also: → 1644248
Status: UNCONFIRMED → NEW
Ever confirmed: true

Just a side note:
It already seemed to be fixed (and still works) in Firefox 78 Developer version. But in Firefox 78 release the bug still occurs. I guess there are some additional differences between the release and developer versions?

I confirm that the issue is fixed in Firefox Developer Edition 79.0b2 (64 bit)
I don't have Firefox Nightly installed so can't test it.

Flags: needinfo?(luca)

(In reply to robbendebiene from comment #4)

It already seemed to be fixed (and still works) in Firefox 78 Developer version. But in Firefox 78 release the bug still occurs. I guess there are some additional differences between the release and developer versions?

Right, there's a preference called devtools.responsive.browserUI.enabled which is currently set to true for only Nightly and Developer Edition. This fixes a number of issues like this and will be available in Firefox 79.

(In reply to XXVII from comment #5)

I confirm that the issue is fixed in Firefox Developer Edition 79.0b2 (64 bit)
I don't have Firefox Nightly installed so can't test it.

Awesome! Thank you for confirming :)

(In reply to Micah Tigley [:mtigley] from comment #6)

(In reply to robbendebiene from comment #4)

It already seemed to be fixed (and still works) in Firefox 78 Developer version. But in Firefox 78 release the bug still occurs. I guess there are some additional differences between the release and developer versions?

Right, there's a preference called devtools.responsive.browserUI.enabled which is currently set to true for only Nightly and Developer Edition. This fixes a number of issues like this and will be available in Firefox 79.

So it is possible to set it to true in Firefox 78 (stable release) to solve the bug in the meantime?

(In reply to XXVII from comment #7)

So it is possible to set it to true in Firefox 78 (stable release) to solve the bug in the meantime?

Yes, you can do that. One thing to note is that you should make sure Responsive Design Mode is closed before setting the preference to true to avoid any unexpected behavior. But after that, you should be good to go.

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.