Closed Bug 1649854 Opened 1 year ago Closed 1 year ago

Extraneous '?' added

Categories

(Thunderbird :: Untriaged, defect)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1435903

People

(Reporter: jw.cross, Unassigned)

Details

Attachments

(2 files)

115.66 KB, application/pdf
Details
18.04 KB, message/rfc822
Details
Attached file Example.pdf

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36

Steps to reproduce:

When I Forward or reply to e-mails I have received.

Actual results:

When I go to edit the orignal message, it now has one or more extraneous question marks in unexpected places '?'

Expected results:

No extraneous '?' should be added.

If the font used in your mail composer does not have glyphs for those characters, then these characters are shown as question marks. I do not see a bug in Thunderbird here but instead in the font that you're using in the mail composer.

The font that I am using in the mail composer is "variable width". That font does not show up in any other program that allows selection of fonts. Previously I have uninstalled and re-installed Thunderbird without any effect on the extraneous '??".

As that it is not the name of a font, it means that Thunderbird picks up whatever your operating system has set as the default font for displaying characters in variable width.

(In reply to Andre Klapper from comment #3)

As that it is not the name of a font, it means that Thunderbird picks up whatever your operating system has set as the default font for displaying characters in variable width.

None of my other software displays extraneous ? It only appears using Thunderbird replies and forward.

What's the exact letter(s) (in Unicode) supposed to be displayed instead of a question mark? Can you take a look into the actual source of the email?

(In reply to Andre Klapper from comment #5)

What's the exact letter(s) (in Unicode) supposed to be displayed instead of a question mark? Can you take a look into the actual source of the email?

The letter that is supposed to be displayed is a space " ". According to a Google search that corresponds to U+0020. I have no idea how to "look into the actual source". I'm not a computer geek, just reporting a problem with Thunderbird.

If you will tell me the steps in detail, I would be glad to do the checking you ask. Or, iff I saved the e-mail as an *.eml file and sent it to you, could you check it as you propose? Give me your e-mail address and I will send the *.eml file to you.

(In reply to John Cross from comment #6)

(In reply to Andre Klapper from comment #5)

What's the exact letter(s) (in Unicode) supposed to be displayed instead of a question mark? Can you take a look into the actual source of the email?

The letter that is supposed to be displayed is a space " ". According to a Google search that corresponds to U+0020. I have no idea how to "look into the actual source". I'm not a computer geek, just reporting a problem with Thunderbird.

If you will tell me the steps in detail, I would be glad to do the checking you ask. Or, iff I saved the e-mail as an *.eml file and sent it to you, could you check it as you propose? Give me your e-mail address and I will send the *.eml file to you.

I have attached a requested source as a *.eml file to the original bug report. The file is named example.eml

Attached file example.eml

Original eml file with extraneous '?'

Flags: needinfo?(jw.cross)

Comment on attachment 9161388 [details]
example.eml

I tried to attach an eml file to the my report, but the effort failed to work.

Flags: needinfo?(jw.cross)

(In reply to John Cross from comment #9)

Comment on attachment 9161388 [details]
example.eml

I tried to attach an eml file to the my report, but the effort failed to work.

It looks like it did get attached anyway. Look for example.eml

(In reply to Andre Klapper from comment #3)

As that it is not the name of a font, it means that Thunderbird picks up whatever your operating system has set as the default font for displaying characters in variable width.

(In reply to Andre Klapper from comment #5)

What's the exact letter(s) (in Unicode) supposed to be displayed instead of a question mark? Can you take a look into the actual source of the email?

Look at the file example.eml to see the actual source.

Possible dupe of bug 1435903?

(In reply to WaltS48 [:walts48] from comment #12)

Possible dupe of bug 1435903?

per bug 1435903,
The problem looks very similar. It only happens for 2 spaces in a row.

  1. My servers are at aol.com, not Yahoo.
  2. Also as suggested in the workarounds for bug 1435903, I tried setting config editor to "mail.strictly_mime" , but it was already set to "true".

Please ignore comment 14, which has a typo. Here is the exact situation:

I did a test e-mail and proved to myself that the extraneous ? are added when I write an e-mail with 2 consecutive spaces and it gets sent back to me.

I sent this to my partner on a different computer but also running Thunderbird: "test test test test "
What she saw on her screen was the same as I sent, but when she replied the message back to me this is what Thunderbird
displayed: "test test?? test?????? test "

Reporter, does this happen for you when using version 78? You can update by going to help > about.

Whiteboard: [closeme 2020-09-25]
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Whiteboard: [closeme 2020-09-25]
Duplicate of bug: 1435903
You need to log in before you can comment on or make changes to this bug.