bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Pop-up window for search does not accept keyboard input

VERIFIED DUPLICATE of bug 78928

Status

()

Core
Keyboard: Navigation
--
major
VERIFIED DUPLICATE of bug 78928
16 years ago
16 years ago

People

(Reporter: James Armstrong, Assigned: Akkana Peck)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
I am running RedHat Linux 7.2 (Linux 2.4.7-10) on a PIII processor.  I am
running Mozilla BuildID 2002082200.

Hitting Edit->Find in Page or Control-F presents a popup menu for finding text
on a page.  When I attempt to type in the input box on the popup, no keystrokes
are registered.  I can go to an xterm and type what I want, and use cut and
paste via the mouse to enter the search string, but the Find button is not
activated, so searching on a page is not possible.

Comment 1

16 years ago
And this is consistent? Does it only happen w/ specific profiles? Have you found
a way to get around it?

I find it really surprising that no one else is reprorintg this, or bug 165013.
I think it must be something specific to the platform/settings/environment
you're running on.
(Reporter)

Comment 2

16 years ago
Probably the only oddity in my environment is that I am running twm as a window
manager (instead of Gnome or KDE), on top of X11R6.  There does not appear to be
anything in my shell environment that is unusual, and I have only one profile on
the system.

The problem is consistent.  I get around the authorization (Bug 165013) with Cut
and Paste.  I've not yet found a workaround for searching a page.

If there are any questions concerning my X configuration or twm configuration,
please feel free to ask.  
(Reporter)

Comment 3

16 years ago
Created attachment 96942 [details]
X Configuration File

This is my X Configuration, as generated by xconfig
(Reporter)

Comment 4

16 years ago
Created attachment 96944 [details]
.xinitrc

This is my X startup script
(Reporter)

Comment 5

16 years ago
Created attachment 96946 [details]
.twmrc

My .twmrc configuration file
(Assignee)

Comment 6

16 years ago
I'm mystified.  I'm running icewm, no gnome or kde, and I always do my searches
using the keyboard (I often don't touch the mouse at all after moving focus into
the mozilla window).  Have you tried with another window manager?  (E.g. move
.xinitrc aside then startx and let the system default to gnome or kde or
whatever).  It does sound like some sort of funky window manager focus problem.
 Maybe also try toggling between pointer focus and click focus and see if that
makes any difference?

Comment 7

16 years ago
-> Akkana
Assignee: aaronl → akkana
(Reporter)

Comment 8

16 years ago
The focus works with Gnome.  If I add:

"F8" = : all : f.focus

to my .twmrc file, and hit F8 on entering the popup window, it works.  If I add 
NoTitleFocus to my .twmrc file, it does not work.

I should mention that other pop-ups have always worked.  This includes the
browse menu for <input type=file...>, javascript popups, and download popups. 
Only the search and authorization pop-ups did not get focus by default.
This is the famous "focus in twm is confused" bug.  See especially bug 78928
comment 39 for the problem description and workarounds.

*** This bug has been marked as a duplicate of 78928 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
mass-verification of Duplicates.

mail search string for bugspam: SolarFlaresAreTheCause
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.