Closed Bug 1650243 Opened 1 month ago Closed 1 month ago

When muting / unmuting devices on some calls, the minimized indicator restores itself

Categories

(Firefox :: Site Permissions, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Firefox 80
Tracking Status
firefox-esr78 --- disabled
firefox78 --- disabled
firefox79 --- disabled
firefox80 --- fixed

People

(Reporter: mconley, Assigned: mconley)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

According dbaron, when on calls using Jitsi, whereby or WebEx, if he minimizes the indicator, and then mutes or unmutes his microphone, then the indicator restores itself.

Since the user has explicitly minimized the indicator, we can presume that they want it out of the way. The only reason I can think of where we might want to restore it is if the set of devices being shared changes in some way that obligates us to inform the user about.

FYI, this happens on both https://whereby.com/ and https://meet.jit.si, but does not happen on Google Meet. I can't test WebEx now because I don't have the ability to schedule one.

Thanks - I've updated comment 0 to remove the reference to Google Meet.

Severity: -- → S3
Priority: -- → P2

window.sizeToContent causes a minimized window to be restored, so we skip calling that if the
indicator is minimized. We call it instead once the indicator is restored.

Assignee: nobody → mconley
Status: NEW → ASSIGNED
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f507e55039d7
Don't accidentally restore the WebRTC global sharing indicator if it is minimized when changing streams. r=pbz

It does also happen on WebEx (on 40.6.1.179, at least).

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 80

Previously, the Global Sharing Overlay came into focus by itself when the sharing permission changed, for example, when stopping or turning on the camera on Zoom. Now, it DOES NOT get back into focus anymore. Is this the correct/expected behavior?

I would assume the user would want to see if any permissions change; when they change.

P.S. meet.jit.si or whereby.com WebRTC web-app aren't the case since the permissions aren't changed when muting camera or microphone, but zoom and webex are the case when stoping the camera, but not the microphone (for these 2 apps, stopping the camera means removing the camera sharing permission altogether).

What do you think, Mike?

Flags: needinfo?(mconley)

I spoke with UX, and yes - if the user has expressed that they want the indicator minimized, we should honour that even if the composition of the streams change.

Flags: needinfo?(mconley)
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.