Closed Bug 1651096 Opened 2 years ago Closed 4 months ago

Crash in [@ java.lang.IllegalStateException: at mozilla.components.browser.engine.gecko.GeckoEngineView$currentGeckoView$1.onAttachedToWindow(GeckoEngineView.kt:5)]

Categories

(Fenix :: Stability, defect, P1)

Tracking

(firefox96+ wontfix, firefox97+ wontfix, firefox98+ wontfix, firefox99+ fixed)

RESOLVED FIXED
Tracking Status
firefox96 + wontfix
firefox97 + wontfix
firefox98 + wontfix
firefox99 + fixed

People

(Reporter: st3fan, Assigned: agi)

References

Details

(Keywords: crash)

Crash Data

This the third top crasher in Fenix 79b4 and 79b5 currently.

This bug is for crash report bp-ccbba9a1-f06d-4bfb-914d-c55410200707.

Java stack trace:

java.lang.IllegalStateException
	at mozilla.components.browser.engine.gecko.GeckoEngineView$currentGeckoView$1.onAttachedToWindow(GeckoEngineView.kt:5)
	at android.view.View.dispatchAttachedToWindow(View.java:19614)
	at android.view.ViewGroup.dispatchAttachedToWindow(ViewGroup.java:3432)
	at android.view.ViewGroup.dispatchAttachedToWindow(ViewGroup.java:3439)
	at android.view.ViewGroup.dispatchAttachedToWindow(ViewGroup.java:3439)
	at android.view.ViewGroup.dispatchAttachedToWindow(ViewGroup.java:3439)
	at android.view.ViewGroup.dispatchAttachedToWindow(ViewGroup.java:3439)
	at android.view.ViewGroup.dispatchAttachedToWindow(ViewGroup.java:3439)
	at android.view.ViewGroup.dispatchAttachedToWindow(ViewGroup.java:3439)
	at android.view.ViewGroup.dispatchAttachedToWindow(ViewGroup.java:3439)
	at android.view.ViewGroup.dispatchAttachedToWindow(ViewGroup.java:3439)
	at android.view.ViewGroup.dispatchAttachedToWindow(ViewGroup.java:3439)
	at android.view.ViewGroup.dispatchAttachedToWindow(ViewGroup.java:3439)
	at android.view.ViewRootImpl.performTraversals(ViewRootImpl.java:2056)
	at android.view.ViewRootImpl.doTraversal(ViewRootImpl.java:1749)
	at android.view.ViewRootImpl$TraversalRunnable.run(ViewRootImpl.java:7692)
	at android.view.Choreographer$CallbackRecord.run(Choreographer.java:966)
	at android.view.Choreographer.doCallbacks(Choreographer.java:790)
	at android.view.Choreographer.doFrame(Choreographer.java:725)
	at android.view.Choreographer$FrameDisplayEventReceiver.run(Choreographer.java:951)
	at android.os.Handler.handleCallback(Handler.java:883)
	at android.os.Handler.dispatchMessage(Handler.java:100)
	at android.os.Looper.loop(Looper.java:241)
	at android.app.ActivityThread.main(ActivityThread.java:7617)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:492)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:941)

This is an Android Components crash

Component: General → Stability
Product: GeckoView → Fenix
Version: 79 Branch → unspecified
Flags: needinfo?(kbrosnan)
Duplicate of this bug: 1621962
Duplicate of this bug: 1646251
Crash Signature: [@ java.lang.IllegalStateException: at mozilla.components.browser.engine.gecko.GeckoEngineView$currentGeckoView$1.onAttachedToWindow(GeckoEngineView.kt:5)] → [@ java.lang.IllegalStateException: at mozilla.components.browser.engine.gecko.GeckoEngineView$currentGeckoView$1.onAttachedToWindow(GeckoEngineView.kt:5)] [@ java.lang.IllegalStateException: at mozilla.components.browser.engine.gecko.GeckoEngineView.ren…
Depends on: 1659850
Crash Signature: [@ java.lang.IllegalStateException: at mozilla.components.browser.engine.gecko.GeckoEngineView$currentGeckoView$1.onAttachedToWindow(GeckoEngineView.kt:5)] [@ java.lang.IllegalStateException: at mozilla.components.browser.engine.gecko.GeckoEngineView.ren… → [@ java.lang.IllegalStateException: at mozilla.components.browser.engine.gecko.GeckoEngineView$currentGeckoView$1.onAttachedToWindow(GeckoEngineView.kt:9)] [@ java.lang.IllegalStateException: at mozilla.components.browser.engine.gecko.GeckoEngineView$cur…
Duplicate of this bug: 1662963
Duplicate of this bug: 1660067
Crash Signature: java.lang.IllegalStateException: at org.mozilla.geckoview.GeckoSession.acquireDisplay(GeckoSession.java)] → java.lang.IllegalStateException: at org.mozilla.geckoview.GeckoSession.acquireDisplay(GeckoSession.java)] [@ java.lang.IllegalStateException: at mozilla.components.browser.engine.gecko.GeckoEngineView.render(GeckoEngineView.kt:21)]
Duplicate of this bug: 1666259
Crash Signature: java.lang.IllegalStateException: at org.mozilla.geckoview.GeckoSession.acquireDisplay(GeckoSession.java)] [@ java.lang.IllegalStateException: at mozilla.components.browser.engine.gecko.GeckoEngineView.render(GeckoEngineView.kt:21)] → java.lang.IllegalStateException: at org.mozilla.geckoview.GeckoSession.acquireDisplay(GeckoSession.java)] [@ java.lang.IllegalStateException: at mozilla.components.browser.engine.gecko.GeckoEngineView.render(GeckoEngineView.kt:21)] [@ java.lang.Illegal…
Crash Signature: java.lang.IllegalArgumentException: at mozilla.components.browser.engine.gecko.GeckoEngineView.rebind(GeckoEngineView.kt:9)] → java.lang.IllegalArgumentException: at mozilla.components.browser.engine.gecko.GeckoEngineView.rebind(GeckoEngineView.kt:9)] [@ java.lang.IllegalStateException: at mozilla.components.browser.engine.gecko.GeckoEngineView.render(GeckoEngineView.kt:18)]

I can reproduce this constantly on Nightly 201105 05:01 (Build #2015773801) GV 84 from 11/5 with Samsung Galaxy Tab S3 (Android 8).

Steps to reproduce:

  1. Launch Fenix;
  2. Open one or more tabs in normal browsing;
  3. Go to private browsing and open one or more tabs;
  4. Tap the "Close private tabs" Notification.

Expected result:

Private tabs are closed.

Actual result:

Fenix crashes.
https://crash-stats.mozilla.org/report/index/8717866f-f705-4577-87a0-582bf0201105

Notes

This issue is not reproducible when there are no opened tabs in normal browsing.
Not reproducible on Beta 83.0.0-beta.2 and Release 82.1.1

Eliza, can you still reproduce this? This is still one of the top Fenix crashes.

Flags: needinfo?(eliza.balazs)

I had tested this on Nightly 4/21, Beta 89.0.0-beta.1 and RC 88.1.1 with Samsung Galaxy Tab S3 (Android 8) and could not reproduce the crash.

Flags: needinfo?(eliza.balazs)

This is still our #1 topcrash for both Fenix and Focus. Is there anything we can do to try to get this fixed, Amedyne?

Crash Signature: java.lang.IllegalArgumentException: at mozilla.components.browser.engine.gecko.GeckoEngineView.rebind(GeckoEngineView.kt:9)] [@ java.lang.IllegalStateException: at mozilla.components.browser.engine.gecko.GeckoEngineView.render(GeckoEngineView.kt:18)] → java.lang.IllegalArgumentException: at mozilla.components.browser.engine.gecko.GeckoEngineView.rebind(GeckoEngineView.kt:9)] [@ java.lang.IllegalStateException: at mozilla.components.browser.engine.gecko.GeckoEngineView.render(GeckoEngineView.kt:18)] […
Severity: -- → S1
Priority: -- → P1

No crashes reported from 99 since bug 1741899 landed. Calling this fixed \m/.

Assignee: nobody → agi
Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(amoya)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.